ToupView Help Manual

ToupView Help Manual ................................................................. 1

1 How to start? ................................................................. 1
   1.1 Start ........................................................................ 1
   1.2 Create the camera video window................................. 1

2 Video window GUI ............................................................... 2
   2.1 Video window GUI .................................................... 2
   2.2 How to close the video window? ................................. 3

3 Image window GUI .............................................................. 4
   3.1 Image window GUI .................................................... 4
   3.2 How to close the image window? ................................. 4

4 UI toolbar ........................................................................ 7

5 Camera Sidebar ................................................................. 8
   5.1 Camera List ............................................................. 8
   5.2 Capture & Resolution group ........................................ 8
   5.3 Exposure & Gain group ............................................. 8
   5.4 White Balance group ............................................... 9
   5.5 Color Adjustment group ........................................... 9
   5.6 Frame Rate group .................................................... 10
   5.7 Flip group ............................................................... 10
   5.8 Color/Gray group .................................................... 10
   5.9 Power Frequency group ........................................... 10
   5.10 Sampling group ..................................................... 11
   5.11 Histogram group ................................................... 11
   5.12 Parameters group ................................................... 12

6 File ............................................................................ 13
   6.1 Open Image••• Ctrl+O ............................................. 13
   6.2 Open Video••• ......................................................... 15
   6.3 Open Broadcast••• ................................................... 16
   6.4 Camera List ............................................................. 16
Contents

6.5 Twain: Select Device

6.6 Twain: Acquire

6.7 Save Ctrl+S

6.8 Save As

6.9 Batch Save

6.10 Quick Save CTRL+Q

6.11 Paste as New File

6.12 Print Setup

6.13 Print Preview Ctrl+Shift+P

6.14 Print Ctrl+P

6.15 Recent Files

6.16 Exit

7 Edit

7.1 Undo/Redo Ctrl+Z

7.2 Forward

7.3 Backward

7.4 Cut Ctrl+X

7.5 Copy Ctrl+C

7.6 Paste Ctrl+V

7.7 Image Select

7.8 Select All Ctrl+A

7.8.1 Select all on the background layer

7.8.2 Select all objects over the background layer

7.8.3 Select all files in the browse window

7.9 Select None Ctrl+D

7.10 Inverse Selection

7.11 Delete File Delete

8 View

8.1 Browse Ctrl+B

8.1.1 Open the browse window

8.1.2 Browse window right mouse button context menu

8.2 Measurement Sheet

8.2.1 File Import
Contents

8.2.2 File Save................................................................. 39
8.2.3 Export> To Html File ............................................... 39
8.2.4 Export to Excel ...................................................... 39
8.2.5 Auto Highlight ....................................................... 39
8.2.6 Settings................................................................. 39
8.3 Sort ............................................................................. 40
8.3.1 Sort>Sort by Names .................................................. 40
8.3.2 Sort>Sort by Type ..................................................... 40
8.3.3 Sort>Sort by Size ..................................................... 40
8.3.4 Sort>Sort by Width ................................................... 41
8.3.5 Sort>Sort by Height .................................................. 41
8.3.6 Sort>Ascending ....................................................... 41
8.3.7 Sort>Descending ..................................................... 41
8.4 Icon ............................................................................. 41
8.4.1 Icon>Large Icons ..................................................... 41
8.4.2 Icon>Small Icons ..................................................... 41
8.5 Refresh F5 ................................................................. 42
8.6 Sidebar ......................................................................... 42
8.6.1 Sidebar overview ...................................................... 42
8.6.2 Sidebar>Camera ....................................................... 43
8.6.3 Sidebar> Folders ....................................................... 43
8.6.4 Sidebar>Undo/Redo .................................................... 44
8.6.5 Sidebar>Layer .......................................................... 44
8.6.6 Sidebar>Measurement .............................................. 45
8.7 Ruler and Grid .......................................................... 45
8.7.1 Grids>No Grids ......................................................... 45
8.7.2 Grids>Manual Grids .................................................. 45
8.7.3 Grids>Auto Grids ...................................................... 46
8.7.4 Grids>Remove All Grids ............................................ 47
8.7.5 Settings................................................................. 47
8.8 Best Fit ......................................................................... 48
8.9 Actual Size ............................................................... 48
8.10 Track ......................................................................... 48
8.11 Properties ................................................................. 48

9 Setup ............................................................................. 50
  9.1 Start/Pause Pause .................................................. 50
  9.2 Full Screen ESC ...................................................... 50
  9.3 View Properties••• .................................................. 50
  9.4 Video Overlay••• ..................................................... 51
    9.4.1 Video Overlay: Overlay .................................. 51
    9.4.2 Video Overlay: Marker••• .............................. 52
  9.5 Video Watermark••• ................................................. 53
  9.6 Move Watermark .................................................... 55
    9.6.1 Move to••• ....................................................... 55
    9.6.2 Move to zero .................................................... 55
  9.7 Rotate Watermark ................................................... 55
    9.7.1 Rotate to••• ....................................................... 55
    9.7.2 Rotate to zero ................................................... 56
  9.8 Gray Calibration••• .................................................. 56
  9.9 Video Source Property••• ........................................... 57
  9.10 Video Stream Format••• .......................................... 57
  9.11 Still Image Options••• ............................................. 58

10 Capture ........................................................................ 60
  10.1 Capture Image F8 .................................................... 60
  10.2 Time-lapse (Auto Capture)••• .................................. 60
  10.3 Start Record••• F9 ...................................................... 61
  10.4 Start Broadcast••• .................................................... 64

11 Image .......................................................................... 67
  11.1 Mode ...................................................................... 67
    11.1.1 Color Quantize••• ............................................ 67
    11.1.2 Gray Scale ....................................................... 67
  11.2 Adjust .................................................................... 67
    11.2.1 Curve••• ......................................................... 67
    11.2.2 Auto Level ....................................................... 69
    11.2.3 Auto Contrast .................................................. 70
    11.2.4 Histogram Equalization .................................... 71
11.2.5 Brightness/Contrast ................................................. 71
11.2.6 Color ................................................................. 72
11.2.7 HMS ................................................................. 74
11.2.8 Gamma .............................................................. 74
11.2.9 Filter Color ........................................................... 74
11.2.10 Extract Color ....................................................... 75
11.2.11 Invert ................................................................. 75
11.3 Rotate ................................................................. 75
  11.3.1 90(CW) .............................................................. 75
  11.3.2 180(CW) ............................................................ 75
  11.3.3 270(CW) ............................................................ 75
  11.3.4 Arbitrary ............................................................ 76
  11.3.5 Flip Horizontal .................................................. 76
  11.3.6 Flip Vertical ...................................................... 76
11.4 Crop Shift+C ............................................................ 76
11.5 Image Scale ........................................................... 77
11.6 Histogram ............................................................ 78
11.7 Resolution ........................................................... 80
12 Process ................................................................. 81
  12.1 Filter Shift+F .......................................................... 81
    12.1.1 Image Enhance ................................................. 81
    12.1.2 Edge Enhance ................................................. 84
    12.1.3 Morphological .............................................. 85
    12.1.4 Kernel ......................................................... 88
  12.2 Stitch ............................................................... 89
    12.2.1 Video Stitch ................................................ 89
    12.2.2 Image Stitch ................................................ 90
    12.2.3 Browse Window Stitch ...................................... 92
  12.3 EDF Shift+E .......................................................... 93
    12.3.1 Browse Window EDF ........................................ 93
    12.3.2 Image Window EDF ......................................... 99
    12.3.3 Video Window EDF ......................................... 100
  12.4 Segmentation & Count ........................................... 102
Contents

12.4.1 Watershed (W)** ........................................... 103
12.4.2 OTSU Dark*** .................................................. 106
12.4.3 OTSU Bright (B) *** ......................................... 106
12.4.4 RGB Histogram*** ........................................... 107
12.4.5 HSV Histogram*** ........................................... 111
12.4.6 Color Cubic*** ............................................... 115
12.4.7 Split Objects .................................................. 120
12.4.8 Count Result (T) *** ........................................ 122
12.5 Image Stacking*** .............................................. 123
12.6 Color Composite*** ............................................ 125
12.7 Range*** Shift+R ............................................... 131
12.8 Binary*** Shift+B ............................................... 132
12.9 Pseudo Color*** ................................................ 132
12.10 Surface Plot*** ............................................... 133
12.11 Line Profile*** ............................................... 134
12.12 Mosaic*** ...................................................... 135
13 Layer................................................................. 138
13.1 About layer ...................................................... 138
13.2 Organizing layers .............................................. 138
13.3 Layers for non-destructive measurement and label .......... 138
13.4 Layer Sidebar .................................................. 138
13.5 Layer menu and layer sidebar page context menu .......... 139
13.6 New*** ......................................................... 139
13.7 Remove*** ....................................................... 140
13.8 Current*** ....................................................... 140
13.9 Show/Hide*** .................................................. 140
13.10 Rename*** ..................................................... 140
13.11 Export to Image ............................................... 140
13.12 Export to Microsoft Excel .................................... 140
14 Measurements ..................................................... 141
14.1 Object Select .................................................. 141
14.2 Angle ............................................................. 142
14.3 Point ............................................................. 143
15.2.1 General page.................................................. 162
15.2.2 Length Unit page.............................................. 163
15.2.3 Angle Unit page............................................... 164
15.2.4 Sheet page......................................................... 165
15.2.5 Object page........................................................ 166
15.3 Magnifications...................................................... 166
15.4 Calibrate............................................................... 167
15.5 Edit Dye List......................................................... 170
15.6 Auto Correction.................................................... 172
16 Windows................................................................. 173
16.1 Close All ............................................................ 173
16.2 Reset Window Layout ............................................. 174
16.3 Windows............................................................... 174
17 Help..................................................................... 176
17.1 Help Contents ...................................................... 176
17.2 About ................................................................. 176
1 How to start?

1.1 Start

1. Double click on the desktop icon “ Leer ” to start ToupView;

2. Click the Start button (At your screen bottom left corner) and a Start menu will bring up. Move your mouse over the menu and try to locate ToupView, click to start it.

1.2 Create the camera video window

ToupView will detect all of the cameras that your computer has installed (Here, it is UCMOS03100KPA, a 3.1M pixel CMOS camera) and will append all the camera names as submenu to the File>Camera List menu (Here, the submenu name is “UCMOS03100KPA”).

Choosing the File>Camera List>UCMOS03100KPA will create a video window and start the video stream. The video window will be associated with the name of “Video [UCMOS03100KPA]” (i.e., its title bar name will be “Video [UCMOS03100KPA]”).

There are 3 methods to start the video stream, they are:

<table>
<thead>
<tr>
<th>File&gt;Camera List</th>
<th>Choose the File&gt;Camera List&gt;UCMOS03100KPA (Here, a 3.1M pixel camera is installed) command to create the video window;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera Sidebar</td>
<td>Click the Camera Sidebar (If it is not activated) and the Camera List to expand the Camera List group (if not expanded). Click the camera name (Here it is UCMOS03100KPA) to create the video window;</td>
</tr>
</tbody>
</table>

1
2 Video window GUI

2.1 Video window GUI

A: ToupView;  B: Menu;  C: ToupView toolbar  D: Camera Sidebar;
E: Folders Sidebar;  F: Undo/Redo Sidebar;  G: Layer Sidebar;
H: Measurement Sidebar;  I: Measurement Sheet;  J: Statusbar;
K: Auto Hide button  L: Horizontal ruler;  M: Vertical ruler;
N: Frame Rate  O: Frames captured  P: Current Video sizes
Help Manual

Q: Selected microscope Magnification  R: Current Unit;
AA: Sidebar right mouse button context menu;
AB: Video window right mouse button context menu;
AC: Browse window right mouse button context menu;
AD: Image window right mouse button context menu;
AE: Frame window right mouse button context menu;
AF: Double-click bring up Video Properties dialog;
AG: Double-click bring up Magnification dialog;
AH: Double-click bring up Measurement dialog;
AI: Horizontal Ruler or Vertical Ruler right mouse button context menu

2.2 How to close the video window?
1 Double-clicking the tabbed video window title or clicking x on will close the video window directly;
2 For MDI video window, click x on to close the video window;
3. Choose the Windows>Close All command to close the video window.
3 Image window GUI

3.1 Image window GUI

A: ToupView;  B: The opened file right mouse button context menu on status bar;
C: The opened file name and directory;
D: Double-click bring up opened file Properties dialog;
E: Current image width and height;
F: Double-click bring up Scale Image dialog;
G: Image Zoom ratio, double-clicking will zoom the image to 100%;
H: Zoom ratio right mouse button context menu;
I: Currently selected Unit  J: Double-click bring up Measurement dialog;
K: Image BPP & Resolution;
L: Double-click bring up Resolution Setting dialog;
M: Unit right mouse button context menu.

3.2 How to close the image window?
1. Tabbed window

a) If you have modified an image before attempting to close it, double-clicking the tabbed image window title or clicking x on will bring up a ToupView dialog:

Clicking Yes will save the changes with its old name and close the window quickly, No will close the file immediately with no changes and no warning, or Cancel will cancel the Close command and leave the window there with no changes;

b) If the Image window is snapped from the video window and with number as its title, double-clicking the tabbed image window title or clicking x on will bring up a warning ToupView dialog:

Clicking Yes will bring up the Save As dialog:

Select the driver and folder to which you want your image file saved in the Save in combobox and enter the file name in the File name edit box.
Click **Save** to save the captured image with the specified directory and file name, or **Cancel** to close the **Save As** dialog and return to image window.

Clicking **No** on the ToupView dialog will close the file immediately with no changes and no warning or **Cancel** on the ToupView dialog will cancel the **Close** command and return to image window.

**Note:** Choosing the **Windows>Close All** command can also close the tabbed image window. Check the **Windows>Close All** for detail.

2. MDI window

a) For an opened and modified image window, click X on ![X button] to bring up the same ToupView dialog. The next operations are just the same as the tabbed window in step 1a;

b). For a Video captured image with number as its title, clicking X on ![X button] will bring up the same ToupView dialog. The next operations are just the same as step 1b in the tabbed window

**Note:** Choosing the **Windows>Close All** command will also close the MDI image windows in a quick way. Check the **Windows>Close All** for detail.
4 UI toolbar

When the camera is started or the image is opened, most of the icons on the toolbar will be available for the quick setup of the video or image characteristic.

1: Open (Ctrl + O)  
2: Save (Ctrl + S)  
3: Quick Save (Quick Save)  
4: Browse (Ctrl + B)  
5: Unit  
6: Magnification  
7: Zoom  
8: Video/Image Select  
9: Track (enabled only when the video/image sizes large than the window size)  
10: Object Select (will be enabled only when an object is existed on the layer above the background layer)  
11: Angle  
12: Point  
13: Line  
14: Parallel  
15: Two Parallel  
16: Vertical  
17: Rectangle  
18: Round Rect  
19: Ellipse  
20: Circle  
21: Annulus  
22: Two Circles  
23: Arc  
24: Text  
25: Polygon  
26: Calibration (for both video/image window)  
27: Gray Calibration (for video window)  
28: Manual Fusion (for video window)
5 Camera Sidebar

The Camera Sidebar is used for the control of ToupCam camera, it includes 12 groups. The group can be expanded by clicking the group name or clicking the Down Arrow at the right of the group name.

5.1 Camera List

List the cameras connected to the computer that support the Amscope application. Click the camera name will start the camera video window.

5.2 Capture & Resolution group

Snap: Continuously Snap images by clicking it;
Record: Record video stream in wmv/asf or avi format;
Live: Set the video resolution;

Snap: Set the Snap resolution for the image capture process.

5.3 Exposure & Gain group

1. When the Exposure & Gain group is expanded, a green rectangle marked with “Exposure” will be overlaid on the video This marked region is a reference region for judging if the image brightness reach to the Exposure Target value. Drag or resize the Exposure ROI to the dark area will increase the video brightness and drag it to
The **Exposure Target** slider will be disabled in this mode;

3. Tune the microscope light source to a bright state, and then drag the **Exposure Time** slider left or right until the image brightness is normal;

4. If and only if the microscope light intensity is too low to meet the **Exposure Time** up limit, drag the **Gain** slide right until the video brightness is normal;

5. The exact **Exposure Time** can also be entered by clicking the edit box at the right of the **Exposure Time**: This will bring up a dialog called **Exposure Time**. You can type the number in the field to set the exact **Exposure Time** value.

### 5.4 White Balance group

1. Click the **White Balance** bar to expand the **White Balance** group and a red rectangular marked with **White Balance** will be overlaid on the video window;

2. Drag or resize the red rectangle to a pure white or gray area and click the **White Balance** button to establish the video **White Balance** for future video streaming process;

3. If the automatic setting and the actual result still has deviation, drag the **Temperature** and **Tint** slides to left or right to manually correct the **White Balance**.

### 5.5 Color Adjustment group

1. **Hue**: Adjusts the **Hue** of the video. Drag the slider to the right to increase or drag to the left to decrease hue;

2. **Saturation**: Adjusts the **Saturation** of the video. Drag the slider to the right to increase or drag to the left to decrease video saturation;

3. **Brightness**: Adjusts the video **Brightness**. Drag the slider to the right to increase or drag to the left to decrease the video brightness;
4. **Contrast**: Adjusts the video Contrast. Drag the slider to the right to increase or drag to the left to decrease the video contrast;

5. **Gamma**: Adjusts the video Gamma. Drag the slider to the right to increase or drag to the left to decrease the video gamma;

6. **Defaults**: Click the Defaults to clear all the changes and reset them to default ones;

7. All of your settings will be saved for future Color Adjustment application.

### 5.6 Frame Rate group

Drag the slider to the right (High) to ensure that the camera can run the video at the fastest Frame Rate that your computer USB hub supports. If the video fails to display, drag the slider to the left (Low) to reduce the Frame Rate and enable the video in a low speed mode.

### 5.7 Flip group

If the video on the screen appears in different directions from what is viewed under the camera, check the “Horizontal” or “Vertical” box to set the video direction to the right one.

### 5.8 Color/Gray group

If you wish to preview Color video, select the “Color” button;

If you wish to preview Gray video, check the “Gray” button.

### 5.9 Power Frequency group

1. A CMOS sensor captures each row of pixels (from top to bottom) in sequential order, creating a rolling effect, hence the name "Rolling Shutter". Instead of being relatively constant, so for example, as the commercial main frequency in Europe is 50Hz, fluorescent lights in Europe flicker at 100 times per second and as the main frequency in US is 60Hz, so in the USA they flicker at 120 times per second;

2. This flickering problem is solved by capture row pixels in over the duration of integer number of (n) flicker periods;
3. check 50HZ will delete the rolling dark band for the 50HZ light fluctuation;
4. check 60HZ will delete the rolling dark band for the 60HZ light fluctuation;
5. For DC power, no light fluctuation is existed and no compensation is needed.

5.10 Sampling group

1. Bin: Pixel binning refers to the method of combining (averaging) pixels of blocks of neighboring same color pixels to resize the video the lower resolution;
2. Skip: Also called "Decimation", means that a certain amount of pixels are not read out but skipped (horizontally, vertically or in both axes). This reduces resolution of the resulting video but introduces subsampling artifacts.

5.11 Histogram group

1. A Histogram illustrates how pixels in an image are distributed by graphing the number of pixels at each color intensity level. The Histogram shows detail in the shadows (shown in the left part of the histogram), midtones (shown in the middle), and highlights (shown in the right part). A Histogram can help you determine whether an image has enough detail to make a good correction;
2. This group shows the Histogram of current active video. Two vertical line markers show the upper and lower limits of the intensity levels. These markers can be dragged with mouse. If you are looking at a color image, the Histogram will reflect the RGB(red, green and blue channels histogram at the same time) R(red), G(green), and B(blue) values with lines of the same color;
3. You can also enter directly the desired values in the Left or Right boxes below the Histogram chart for both Left and Right Histogram boundaries;
4. Click the “Refresh” button to update the Histogram display if the sample under observation is moved or changed;
5. Clicking the Defaults button will return the Left and Right Histogram boundaries to its original ones;
6. Click the Auto button to locate the two boundaries automatically to get the best video quality.

5.12 Parameters group

Parameters group is used to save the camera control parameters adjusted for further application.
Click Save will save the current camera control parameters with new parameter file; The Load and Overwrite buttons will be enabled.

Click Load will load the saved camera control parameters;
Click Overwrite will overwrite the current camera control parameters to the current loaded active camera control parameters file;
Click Management will invoke a Management dialog and in this dialog, one can manage all of the saved parameter files.
6  File

6.1 Open Image  Ctrl+O

Choose the File>Open Image command to open an existing image file. The Open Image command can also be used to preview an image in small size, or to view its statistics and information without actually opening the image itself. These capabilities can be used to quickly locate a particular image.

ToupView supports and can open many image formats. These are identified in the Files of type list box. You may also open an image file type with ToupView File Type (*.tft) format which has Measurement Objects overlaid on the image.

More than one image can be opened within ToupView simultaneously by a) with Ctrl + left mouse button method and b) Shift + left mouse button method to highlight the files to be opened;

When opening an image, ToupView places it into a new image window. It then becomes the active image.

Note: ToupView maintains, at the File>Recent Files submenu, a list of the last 4(}
be 1-8) opened files. Any of these files can be accessed by simply clicking on file name. If no files are listed in the **File>Recent Files** submenu, the **Open Image**** command must be used to open the file.

Also, the **View>Browse** can be used to view images in an **Icon** format under any selected directory. Brief information is given in the **View>Browse** menu.

| **File name** | From this list box, select the name of the file want to open. Either the type of the file name (with its entire path, if it is not in the current folder), or selecting **Files of type** to obtain a list of file names. Double-clicking a file name in the large combobox (where both folder and file names are listed) will automatically open it.  
**Note:** If just type in the file name, be sure that the **Files of type** field correctly identify the format of the file to open. Otherwise error messages will bring up when ToupView tries to open the file. |
| **Files of type** | In this list box, select the image format of the file to open. If one selects **All supported formats**, ToupView uses the file's extension to identify its format. ToupView supports the following file formats:  
Window Bitmap(*.bmp,*.dib,*.rle)  
JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)  
Portable Network Graphics(*.png)  
Tag Image File Format(*.tif, *.tiff)  
CompuServe GIF (*.gif)  
Targa(*.tga)  
PhotoShop(*.psd)  
ICON(*.ico)  
Enhanced Window Metafile(*.emf)  
Window Metafile(*.wmf)  
JBIG(*.jbg)  
Wireless Bitmap(*.wbmp)  
ToupView File Type(*.tft)  
If the image file does not use standard format-identifying extensions, the file in the **File name** field must be typed, and then select its format from the **Files of type** list box. Otherwise, ToupView will select a format |
based on the file name extension.

| Preview | Click this button to preview image in small size. In preview mode, statistics and information about the image (i.e. image Width, Height and image location) will be displayed. The default is no Preview. |
| Current File | Current File location on your computer |
| Width | Current File image width; |
| Height | Current File image height; |

6.2 Open Video

The File>Open Video menu will be enabled only when there is no video file opened in the ToupView frame or no camera start up.

1. Choose the File>Open Video command to open an existing video file;

![Image of Open Video dialog]

2. Select the name of the file you want to open. If the file does not appear, select the option for showing all files from the Files of Type combobox. The video file type can be *.wmv*, *.asf* or *.avi* format.

3. Click Open to open a video file, this will create a video window and begin to start the video stream. The video window will be associated a name called “Video [XXX.XXX]” (i.e., its title bar will display “Video [XXX.XXX]”, here, XXX.XXX is the video file name).
4. Click **Cancel** to return to the application.

**Note:** Only a single video can be opened at a time. ToupView takes camera as an special video file, if the camera is started, this menu will be disabled and the video file cannot be opened anymore.

### 6.3 Open Broadcast

Users could receive the broadcasting video by ToupView from the other user by the IP and port. For example, if a user starts a broadcasting service via IP 192.168.0.20 and port 2080, the other users could share the video that is opened on 192.168.0.20 by inputting the right IP and port. The performance will depend on the bandwidth of the users. If the receiver and the broadcaster are in one intranet, the performance will be excellent. If not, the performance will depend on the bandwidth.

### 6.4 Camera List

The **File> Camera List** submenu will be disabled when there is a video file opened in the ToupView frame or a camera start up.

ToupView will detect all of the cameras that your computer has installed (Here, it is **UCMOS03100KPA**, a 3.1M pixel CMOS camera) and will append all the camera names as submenu to the **File>Camera List** menu (Here, the submenu name is “UCMOS03100KPA”).

Choosing the **File>Camera List>UCMOS03100KPA** will create a video window and start the video stream. The video window will be associated with the name of “**Video [UCMOS03100KPA]**” (i.e., its title bar name will be “**Video [UCMOS03100KPA]**”).

There are 3 methods to start the video stream, they are:

<table>
<thead>
<tr>
<th><strong>File&gt;Camera List</strong></th>
<th>Choose the <strong>File&gt;Camera List&gt;UCMOS03100KPA</strong> (Here, a 3.1M pixel camera is installed) command to create the video window;</th>
</tr>
</thead>
</table>
Click the Camera Sidebar (If it is not activated) and the Camera List group to expand it (if not expanded). Click the camera name (Here it is UCMOS03100KPA) to create the video window;

<table>
<thead>
<tr>
<th>Camera Sidebar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click the Camera Sidebar (If it is not activated) and the Camera List group to expand it (if not expanded). Click the camera name (Here it is UCMOS03100KPA) to create the video window;</td>
</tr>
</tbody>
</table>

**Note:** a) Only a single video can be opened at a time. ToupView takes camera as a special video file, if the camera video window is opened, the File>Open Video menu will be disabled and the video file cannot be opened anymore; b) If a video file is opened, the camera cannot be started.

### 6.5 Twain: Select Device

**Twain** is a cross-platform interface for acquiring images captured by certain scanners, digital cameras, or frame grabbers. The manufacturer of the **Twain Device** must provide a **Source Manager** and **Twain Data Source** to work with ToupView.

Select the active device for the **Twain: Acquire** menu from all devices available in the device combobox which are enumerated by the application.

One must install the **Twain Device** hardware and its driver first. See the documentations provided by the device manufacturer for the installation instructions.

Before begin to start the **Twain: Acquire** at the first time with ToupView, choose the **File>Twain: Select Device** command first, this will invoke a dialog called Select Source as shown below:

**Source:** Choose the right device from the Source window (Highlight it)

**Select:** Click Select to select the device. User does not need to repeat this step for subsequent choosing of the **Twain: Acquire** command.

### 6.6 Twain: Acquire

**Introduction**

There are basically two techniques used to capture the video images from video.
devices such as a PC camera, digital camera, and scanner. They are the Twain: Acquire technique and the DirectShow technique (previously called VFW).

The most obvious characteristics of the Twain technique is that it previews the video in smaller resolution but captures the image with higher resolution. The USCMOS and UHCCD series cameras support all of these two video preview techniques.

Steps for Twain Acquire

Here we illustrate how to capture the image using a UHCCD01400KPA (1.4M pixels, USB2.0) camera as an example.

1. Install the camera driver (for example driver for UHCCD01400KPA hardware);
2. Install ToupView;
3. Plug the cameras UHCCD01400KPA (USB2.0) into the computer;
4. Start ToupView;
5. Choose the File>Twain: Select Device command to select the device UHCCD01400KPA from the Select Source dialog (If never selected before).
6. Choose the File>Twain: Acquire command. There should be a dialog box like below:
In this dialog, video *Resolution* can be selected (Combobox if it has). The *Video Source Property* can be set by clicking the *Setting* button. Click the *Snap* button to capture an image. This will create a new window and its title bar will be assigned a digital as the image window name;

Check the *RGB/BGR* box to ensure the correct color encoding format compatible with your application.

Click X on ![X](image) to close the *Twain: Acquire* dialog.

**6.7 Save Ctrl+S**

Choose the *File>Save* command to immediately store the current window image to its file (the file name is listed on the window's title bar) while leaving the image still active in its window.

If the image is untitled or titled with a digit, ToupView will issue the *File>Save As* dialog automatically. The default “Save as type” will be “Window Bitmap (*.bmp,*.dib,*.rle)”. If there are *Measurement Objects* overlaid on the image, the default *Save as type* will be “ToupView File Type (*.tft)”.

The *File>Save* command can be used to save the most recent changes to disk. It is
often performed as a precautionary measure during lengthy or involved processes to reduce the amount of reprocessing that might be required in the event of a system failure or operational error. When an image is closed and not to save its changes is chosen, ToupView discards all changes made since the last File>Save operation.

Note: a). The File>Save command always saves the contents of the entire window, even if there is an AOI (Area of Interest) defined on it; b). The File>Save command will be disabled if the file is not changed or the changes have been saved.

6.8 Save As•••
Choose the File>Save As••• command to store the contents of the current window to a specified file format. At the end of a File>Save As••• operation, the image window will be associated with the new file and the new format (i.e., its title bar will display the new file name). ToupView supported file save formats are:

- Window Bitmap(*.bmp,*.dib,*.rle)
- JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)
- Portable Network Graphics(*.png)
- Tag Image File Format(*.tif, *.tiff)
- Compuserve GIF (*.gif)
- PCX(*.pcx)
- Targa(*.tga)
- JBIG(*.jbg)
- ToupView File Type(*.tft)

Save in: Find the folder where the file wishes to be saved. A new folder may be created using the New Folders button.

File name: Enter to be saved file name. To specify the file's location, either enter its entire path (disk and folder), or specify its location using the Save in list box.
Save as type: In this list box, select the format in which the image wants to be saved. Save As is also used to convert a single image from one format to another. For example, if a TIFF file needs to convert to PCX format, open the TIFF image first, then choose Save As command with the PCX format option to save it to a new file.

The default “Save as type” will be “Window Bitmap (*.bmp,*.dib,*.rle)”. If there are Measurement Objects overlaid on the image, the default Save as type will be “ToupView File Type (*.tft)”.

The Save As command has several important uses beyond simply storing an image to a new file name. Click Option to select the different parameters to encode the file.

For JPEG (*.jpg,*.jpeg,*.jpe,*.jif,*.jfif), Option has the following items:
### Help Manual

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image quality</td>
<td>If one save an image in JPEG format (*.jpg), one may adjust image quality in the edit box. The values range from 0 to 100. Default value: 75.</td>
</tr>
<tr>
<td>Progressive</td>
<td>The default is unchecked.</td>
</tr>
<tr>
<td>Optimize Huffman codes</td>
<td>The default is unchecked.</td>
</tr>
<tr>
<td>Smoothing</td>
<td>The values range between 0 and 100. Default value: 0.</td>
</tr>
<tr>
<td>Save these setting as defaults</td>
<td>When saving a file, the current settings will be saved as defaults for the next file save operation.</td>
</tr>
</tbody>
</table>

For Portable Network Graphics (*.png), Option has the following items:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interlaced</td>
<td>The default is unchecked.</td>
</tr>
<tr>
<td>Save these setting as defaults</td>
<td>When saving a file, the current settings will be saved as defaults for the next file save operation.</td>
</tr>
</tbody>
</table>

For Tag Image File Format (*.tif, *.tiff), Option has the following items:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appended pages</td>
<td>Determine whether the current image will be saved in multiple pages style or not.</td>
</tr>
<tr>
<td>Compressions</td>
<td>Specifies a method for compressing the composite image data.</td>
</tr>
</tbody>
</table>
For saving a 32-bit TIFF file, one can specify that the file be saved with predictor compression, but have no option to use JPEG compression. Predictor compression offers improved compression by rearranging floating point values, and works with both LZW and ZIP compression.

| Image quality | If choosing Compressions as "JPEG", the Image quality can be adjusted by the slider bar. The values range between 0 and 100. Default value: 75. |
| Save these setting as defaults | When saving a file, the current settings will be saved as defaults for the next file save operation. |

For Compuserve GIF (*.gif); PCX(*.pcx); Targa(*.tga); JBIG(*.jbg); ToupView File Type(*.tft), There is no Option.

Note: a) Detailed information of the above academic terminologies can be found in books about image processing and image compression or internet; b) The file saved directory can be restored for future application. To keep the directory unchanged when ToupView is started again, choose Options>Preferences... command, click Misc page and check Restore the current directory when startup under the Privacy item.

6.9 Batch Save...

The File>Batch Save... menu will be enabled when a) an image is opened; b) an image is captured from the camera; c) an image window is created by choosing the File>Paste as New File menu; d) an image window is created copied from the
Undo/Redo Sidebar.

Batch Save for the a) style image window

1. If the image is modified, choosing the File>Batch Save command will save the file with its opened file name and file extension;

2. If the image is modified because of the Measurement Objects, choosing the File>Batch Save menu will save the file with its opened file name but with “ToupView File Type (*.tft)” file extension format;

Batch Save for the b), c) or d) style image window

If the image window has been created with b), c) or d) style, choosing the File>Save As command to realize the file saving task will be time-consuming. The Batch Save command will runs File>Save As command with the name automatically specified according to the paradigm specified in the Batch Save dialog

To start the File>Batch Save command, you have to

1. Start the camera;

2. Snap at least an image first;

3. Choosing the File>Batch Save command will bring up a Batch Save dialog:

![](Batch_Save_Dialog.png)

**Directory:** Enter the name of the drive and directory where your captured images will be saved. You may either type the path information, or use the Browse button to locate it from a standard Browse Folder dialog.

**Name Format:** The year, month, date, hour, minute and second or nnnn(sequence)
are used to as part of the file name. If more files are saved with in a second, a (xx) suffix is attached to the end of Name Format to avoid the possible name conflict. For the nnnn(sequence) "Name Format", no suffix is needed.

**File Prefix**: Enter a file name prefix for Batch Save when generating files names for a series of images. This prefix will be combined with Name Format to form a final file name naming paradigm.

**File Type**: In this combobox, select the format in which you want the image to be saved (can be BMP, JPG, PNG, TIF). Click Option button to set the different parameters for encoding the file (For BMP format, the Option will be disabled. See File>Save As menu about the details of the format encoding methods); If there are Measurement Objects over the image, the File Type will be chose as "ToupView File Type (*.tft)" by ToupView.

**Sample**: The final file name is shown at the right of the Sample label for reference.

4, If everything was finished, click OK button to begin the file batch save process or Cancel to cancel the File>Batch Save command and return to the application.

**Note**: a) In the process of the File>Batch Save command, the title on the image tab or image window will be modified with the file name formed in the Batch Save dialog. b) The File>Batch Save will perform no saving operation if the file is not modified.

**6.10 Quick Save**

CTRL+Q

The File>Quick Save menu will be enabled when a)an new image captured from the camera; b)an image window is created by choosing the File>Paste as New File menu.

File>Quick Save can save the file at quick way with no need to specify the file directory, file name and file format. All those are specified in Options>Preferences, Quick Save property page. The file name can be renamed according to the setup in the Options>Preferences, Quick Save property page’s Show the rename dialog item

**6.11 Paste as New File**

The File>Paste as New File menu will be enabled when there is valid image data on
the clipboard first (see the Edit>Copy menu). If there is no image data on the clipboard, the File>Paste as New File menu will be disabled.

Choose the File>Paste as New File command to place the contents of the clipboard image into a new image window, which becomes the active image.

The new image type will be the same as that of the original image. ToupView will accept image data from other applications via the clipboard as long as it is in Windows Bitmap (DIB) format.

**Note:** ToupView will assign a digit to the Paste as New File command created image window title bar.

### 6.12 Print Setup

Choose the File>Print Setup this command to access the setup panel for the printer that has selected. ToupView will present the standard setup panel for the particular printer (this is the same panel one would receive if one were setting up the printer from the Windows Control Panel). Change printer's setup to satisfy the requirements, click OK button to return.

### 6.13 Print Preview

**Ctrl+Shift+P**

Choose the Print Preview command to see the real-time effect of the printer without actually printing it out.

### 6.14 Print

**Ctrl+P**

Choose the File>Print command to print one or more copies of the current image to the selected output device. The ToupView File>Print command lets one take full advantage of the printer's capabilities. If the printer has built-in half-toning or color dithering capabilities, use them or instruct ToupView to perform these processes before sending the image to the device.

The File>Print command also has facilities that let one adjust the size and position of the image on the printed page.

### 6.15 Recent Files

ToupView maintains 4 (default) most recently opened document files under the Recent Files menu. Choosing one of these submenus will reopen that file
immediately.

![Preferences](image)

1. **The maximum number of Recent Files** can be modified by choosing the `Options > Preferences` command and clicking the `Misc` page. Here, clicking the 4 (default) edit box will allow you to enter the number of the Recent Files submenu that you want. The value ranges from 0 to 8, the default is 4;

2. One can also check the **Clear the Recent Files when exit the application** to clear the Recent Files after exit ToupView application.

### 6.16 Exit

Choosing the `File > Exit` command will close video, all of the image windows and **Browse** window and remove their windows from the screen. After all of the windows are closed, ToupView will end itself.

**Note:** If an image has been modified before attempting to **Exit** it, ToupView will issue a warning to ask if user want to save the image or not first.
7 Edit

7.1 Undo/Redo  Ctrl+Z
If the Image or Processing menu’s submenu command is exerted on the image, the Edit>Undo menu will be enabled.

Most of the operations in ToupView can be undone. Alternatively, one can restore all or part of an image to its last saved version. The basic Undo demo process is:

1. Choose the File>Open Image••• command to open an image;
2. Choosing the Image>Adjust>Auto Level command, then the Edit>Undo menu will be enabled;
3. Choosing the Edit>Undo command will cancel the Image>Auto Level operation and return the Operation to its initial opened state.

If return to the Edit menu, one will find that the Edit>Undo menu now is changed to Edit>Redo. You can select one of these two operations to understand the Undo and Redo mechanisms:

1. Choosing the Edit>Redo command will return the image to the Image>Auto Level Operation and the Edit>Undo menu will be enabled again;
2. Choosing the Image>Auto Contrast command, then the Edit>Redo menu will change to Edit>Undo;
Help Manual

Note: ToupView supports only one step Undo and Redo operations.

7.2 Forward
The Edit>Forward menu will be enabled if it is not in the final step in the Undo/Redo Sidebar.

The Edit>Backward menu will be enabled if it is not in the first step in the Undo/Redo Sidebar.

The Edit>Forward command will forward the current displayed image to the next operation listed in the Undo/Redo Sidebar (If it is not in the final step).

Forward Demo
1. Open an image, choose the Image>Adjust>Auto Level and the Image>Adjust>Invert commands; check Current on Index 1(Open Operation). The Undo/Redo Sidebar is shown below in Fig.1

![Undo/Redo Sidebar](image)

Now we continue the Edit>Forward menu demo. Since it is in Index 1, the Edit>Backward menu is disabled and the Edit>Forward menu is enabled.

2. Choosing the Edit>Forward command, the image and the Index will Forward to
Fig. 2. Now the Edit>Backward menu is enabled;

3. Choose the Edit>Forward menu again to go to Index 3 as shown in Fig 3. Now the Edit>Backward menu is still enabled, but because it is in the final operation, the Edit>Forward menu is disabled.

See Edit>Backward for further information.

7.3 Backward
The Edit>Forward menu will be enabled if it is not the final operation in the Undo/Redo Sidebar.

The Edit>Backward menu will be enabled if it is not the first operation in the Undo/Redo Sidebar.

The Edit>Backward command will move the current displayed image to the previous Index listed in the Undo/Redo Sidebar (If it is not in the "Open" status).

Backward Demo
1. Choose the Open Image command to open an image;

2. Exert the Image>Adjust>Auto Level command on the image;

3. Choose the Image>Adjust>Invert command, the final image is shown in Fig 3. Since it is in the final operation state (Fig.3), the Edit>Backward menu will be enabled;

4. Choosing the Edit>Backward command, the image and the Index will Backward to Index 2 as shown in Fig 2. Since it is in Index 2, the Edit>Forward menu will be enabled;

5. Choosing the Edit>Backward command again, both the image and the Index will Backward to Index 1 as shown in Fig.1. Since it is in Index 1, the Edit>Forward menu will still be enabled, but the Edit>Backward menu will be disabled.

See Edit>Forward for further information.
7.4 Cut  Ctrl+X
The Edit>Cut menu will be enabled only when an Object or Objects on the Layer over the image is or are selected.

Check the Measurements>Object Select or Edit>Select All menu about how to select Layer objects for the Edit>Cut menu function.

Choose the Edit>Cut command to copy the selected Measurement Objects to the clipboard and delete the selected Objects on the image. Any data already exist on the clipboard will be replaced.

The data copied to the clipboard can be pasted into the active window or into another opened video/image window on the layer above the image using the Edit>Paste command (when there is no Layer over the Background, create a new Layer with the Layer>New command first).

Note: The Edit>Cut command does not support Background Layer (image) Cut operation.

7.5 Copy  Ctrl+C
When the Measurement Object(s) is (are) highlighted, the Edit>Copy menu will be
When an image ROI is selected and the Current Layer is the Background Layer, the Edit>Copy menu will be enabled.

Choose the Edit>Copy command to Copy the highlighted Objects (on Measurement Layer) or an image's selected area on the Background Layer to the clipboard.

Copy the selected area on the background layer to the clipboard.

1. Select the image area using the Image Select button on the toolbar. The Edit>Copy menu will be enabled;

2. Choose the Edit>Copy command to copy the selected image area to the clipboard.

Copy object(s) on the measurement layer to the clipboard.

1. For the Layer operation, see the View>Sidebar>Layer menu in Sec.8 and the Layer menu in Sec.13 for details;

2. For the Measurement operation, see the View>Sidebar>Measurement menu in Sec.8 and the Measurements menu in Sec.14;

3. After the Measurement operating has been done, choose Measurements>Object Select command or check the Object Select button , the cursor will change to ;

4. Move the mouse until the cursor becomes , this means the cursor is right on the Object. Clicking it will highlight Object and select the Object;

5. Option 1: Continue to move the mouse until the cursor becomes again, this means the cursor is right on another Object again. Clicking it with SHIFT+left mouse button and the second Object will be selected and highlighted;

6. Option 2: a) Move the cursor over the image, click down the left mouse button; b) Drag the mouse to draw a rectangle on the image. A dotted rectangle will appear around the selected area; c) Release the mouse and all of the Measurement Objects within the dotted rectangle will be highlighted and selected;

7. After the Measurement Objects are selected, the Edit>Copy menu will be enabled;
8. Choose the Edit>Copy to Copy the Object(s) to the clipboard. Then the Edit>Paste menu will be enabled. One can then Paste the objects onto the Current Layer or onto the other Measurement Layer in the same video/image window. If one switches to the Background Layer, the Edit>Paste menu will be disabled, but if one returns to the Measurement Layer, the Edit>Paste menu will be enabled again.

Note: a) The Edit>Copy command will not delete the Measurement Objects over the image. Any data existing on the clipboard will be replaced with the new data; b) The copied Object(s) can be pasted into the active window or into another opened window using the Edit>Paste command as long as the current window is not on the Background Layer (the Edit>Paste menu will be disabled if the Background Layer is active). See the View>Sidebar>Layer command in Sec.8 and the Layer menu in Sec.13 for details.

7.6 Paste Ctrl+V
If there is Measurement Object data in the clipboard and the Current Layer is not the Background Layer, the Edit>Paste menu will be enabled.

Choose the Edit>Paste command to Paste Objects from the clipboard onto the active image's Measurement Layer. One can also choose Edit>Paste command to transfer a layer's Measurement Objects from one image window's Measurement Layer to another image window's Measurement Layer.

Note: The Edit>Paste command does not support the image area Paste operation.

7.7 Image Select
The Edit>Image Select command can be used to mark ROI and Copy the selected ROI to the clipboard. This command is only used to select the ROI on the Background Layer.
Choosing the **Edit>Image Select** command will check this menu (or click on the toolbar will keep it down) and the cursor will turn into “+”. After the area is selected and the **Current Layer** is the **Background Layer**, the **Edit>Copy** menu will be enabled and then the selected area can be copied to the clipboard for further application.

To select an area,

1. Choose **Edit>Image Select** command (Or click the **Image Select** button on the toolbar)

2. Drag the mouse cursor across the image with the left button held down until the area is selected.

3. Release the button and the area will be marked. Handles will appear on the area that will allow altering the selection after it is marked.

![Selected area](image)

**Note**: Only when a **ROI** is selected and the **Current** item is checked on the **Background** in the **Layer Sidebar**, the **Edit>Copy** command can copy the selected image **ROI** to the clipboard.

**7.8 Select All   **Ctrl+<n>

**7.8.1 Select all on the background layer**

When the video/image window is active and the **Background Layer** is checked, choosing the Select All command to select all pixels on the **Background layer** within the canvas (shortcut: Ctrl+A).

**7.8.2 Select all objects over the background layer**

When the video/image window is active and the **Background Layer** is not checked, choosing the **Edit>Select All** command will select all of the **Objects** on the **Current**
Layer (shortcut: Ctrl+A).

7.8.3 Select all files in the browse window
When the Browse window is active, choosing the Edit>Select All command will select all of the files in the Browse window under the specified directory in the Folders Sidebar. See Edit>Invert Selection for select all files method.

7.9 Select None          Ctrl+D
Deselect any selected area on the image or the Measurement Objects on a Layer.

1. When the Current Layer is the Background Layer and an image area is selected, the Select None menu will be enabled. Choosing the Edit>Select None command will delete the dotted rectangle representing the selected area;

2. When the Current Layer is not the Background Layer and the Measurement Objects are selected, the Edit>Select None command will be enabled. Choosing the Edit>Select None command will deselect all of the selected Measurement Objects.

Note: See Edit>Image Select, Edit>Select All and Measurements>Object Select to understand how to perform select operations.

7.10 Inverse Selection
This command is for Browse window only.

When organizing files, one can invert a selection in order to select all of the other files that were not previously selected with the Edit>Invert Selection command.

When no files were selected, choosing the Edit>Invert Selection command will select all of files under the Folders Sidebar directory which is just as the Edit>Select All command.

7.11 Delete File          Delete
The Edit>Delete File menu will be enabled if the file(s) is (are) highlighted in the Browse window. This command is for Browse window only.

You can Delete or remove one or more files from the Browse window. The steps are as follows:

1. Select one or more files by a) Clicking the displayed file icons, a single file will be
highlighted; b) Clicking the file one by one with CTRL + left mouse button, all of the clicked files will be highlighted; c) Clicking the displayed file icons, the first clicked file will be highlighted, clicking the end file with Shift + left mouse button, all of the files among the first and last will be highlighted. d) Dragging the mouse to draw a dotted line rectangle across the files you wish to delete, all of the files in the rectangle will be highlighted;

2. a) Press the Delete key to delete the selected files; b) Click you right mouse button to bring up a context menu, choose the Delete command to delete the highlighted files. A Confirm File Delete dialog will bring up.

In the Confirm File Delete dialog, click Yes to move the files to the desktop recycle bin, or No to cancel the Delete operation.
8 View

8.1 Browse  

8.1.1 Open the browse window

1. Choose the View>Browse menu from the View menu or click the Browse toolbar button to browse images under the specified directory in the Folders Sidebar;

2. Click the Folders Sidebar to activate it and double-clicking the listed directory in the Folders Sidebar will create the Browse window.

After creating the Browse window, ToupView will display a Browse window that looks like windows explorer. The child window on the left part of the Browse window called Folders Sidebar is used to locate the directory on the hard disk. Images in the current directory are displayed in Large Icons or Small Icons mode on the right side of the Browse window.

Their order can be set in Forward or Reverse format according to Sort by Name, Type, Size, Width or Height et al.

8.1.2 Browse window right mouse button context menu

Clicking the right mouse button on the listed Icon in the Browse window will bring up a right mouse button context menu as shown below:

These context menu functions are described in

View>Delete File
View>Sort>Sort by Names
View>Sort>Sort by Type
View>Sort>Sort by Size
View>Sort>Sort by Width
View>Sort>Sort by Height
Help Manual

View>Sort>Forward
View>Sort>Reverse
View>Icon>Large Icons
View>Icon>Small Icons
View>Refresh for details

Note: The Folders Sidebar and the Browse can be used to perform tasks such as creating new folders, renaming, moving, and deleting files. Individual file information and import data from digital cameras can also be displayed. Double-clicking the left mouse button on the icon will open the image as an active image in full size. See Image window UI in Sec.3 for more details.

8.2 Measurement Sheet

When choosing the View>Measurement Sheet command, the Measurement Sheet will be active. The Measurement Sheet shows the Object’s possible features, such as Name, Center, Radius, Area, Perimeter, Angle, Start Point, and End Point overlaid on the extra layer.

![Measurement Sheet](image.png)

Clicking the right mouse button on the Measurement Sheet and the right mouse context menu will bring up on the Measurement Sheet window as shown above. They are explained below:
8.2.1 File Import
Choose this command to load a Measurement files (*.measurement) and overlay the Measurement Objects over the current video/image background.

8.2.2 File Save
Choose this command to save the Measurement Objects over the current video/image on the Current Layer to a Measurement files (*.measurement).

8.2.3 Export>Html File
Export all the Layer Measurement Objects to the *.html file in tabbed format.

Note: This menu will be enabled only when there are Measurement Objects over the Background Layer (video/image).

8.2.4 Export to Excel
If this command is chosen, the Current Layer Measurement Objects over the video/image will be exported to Microsoft Excel. The Objects' parameters in the Measurement Sheet will also be arranged as a table.

Note: This menu will be enabled only when there are Measurement Objects on the Current Layer (video/image).

8.2.5 Auto Highlight
When this menu is checked, clicking the row in the Measurement Sheet will Highlight the corresponding Measurement Object over the Background Layer. Clicking the Object over the video/image will Highlight the corresponding row in the Measurement Sheet.

8.2.6 Settings
1. To modify the Measurement Sheet's item order, click the item to highlight it, the Up or Down button will be enabled (If the item is in the third position, the Up button will be disabled, if the item is in the last row, the Down button will be disabled). Click the Up or Down button to modify the item order;

   **Note**: The item Index and Name are always in grayed states, this means these two items cannot be modified (Both their hide/show states and their positions).

2. Checking/Unchecking the item will show/hide the item in the Measurement Sheet;

3. Clicking Default will return to the ToupView's default settings;

4. Item 1(Index) and item 2(Name) cannot be changed.

8.3 Sort

   8.3.1 Sort>Sort by Names
   This command is for the Browse window only.

   Sort the image files in order of names in the Browse window.

   8.3.2 Sort>Sort by Type
   This command is for the Browse window only.

   Sort the image files in order of type in the Browse window.

   8.3.3 Sort>Sort by Size
   This command is for the Browse window only.
Sort the image files in order of size in the Browse window.

8.3.4 Sort>Sort by Width
This command is for the Browse window only.

Sort the image files in order of image width in the Browse window.

8.3.5 Sort>Sort by Height
This command is for the Browse window only.

Sort the image files in order of image height in the Browse window.

8.3.6 Sort>Ascending
This command is for the Browse window only.

Sort the image files in order of the Ascending mode (i.e. 1, 2, 3 and 4) in the Browse window.

8.3.7 Sort>Descending
This command is for the Browse window only.

Sort the image files in order of the Descending mode (i.e. 4, 3, 2 and 1) in the Browse window.

The Sort settings are saved until they are changed. For example, if you sort images in the Browse window according to the Type, the images will remain sorted according to Type until the Sort settings are changed.

8.4 Icon

8.4.1 Icon>Large Icons
This command is for the Browse window only.

The Thumbnail mode displays small preview images; you can select different view modes in the Browse window.

Choosing the Icons>Large Icons will display the image files in Large Icon mode in the Browse window.

8.4.2 Icon>Small Icons
This command is for the Browse window only.
The **Thumbnail** mode displays small preview images; you can select different view modes in the **Browse** window.

Choosing the **Icons>Small Icons** will display the image files in **Small Icon** mode in the **Browse** window.

**8.5 Refresh**  
F5  
This command is for the **Browse** window only.

If the files under the **Folders Sidebar**'s directory are altered outside of ToupView, after switch back to ToupView, one can **Refresh** the image files in the current directory to update the ** Thumbnails** with **View>Refresh** command.

**8.6 Sidebar**  
There are 5 **Sidebar** in the ToupView frame window in tabbed format. They are **Camera Sidebar**, **Folders Sidebar**, **Undo/Redo Sidebar**, **Layer Sidebar** and **Measurement Sidebar**.

**8.6.1 Sidebar overview**

AA: **Camera Sidebar**;  
AB: **Camera Sidebar** groups for the control of the started up camera.

BA: **Folders Sidebar**;  
BB: **Back** to the previous folder;

BC: **Forward** to the next folder;

BD: **Browsing** the pictures under the directory of ToupView’s directory;

BE: Auto hide button to show/hide the current selected directory, this will open the **Browse** window if it is not opened (Double-clicking on the selected directory will perform the same functions.);

BF: **Folders** to locate the **Browse** window’s file directory.
CA: Undo/Redo Sidebar;
CB: Operation Copy: Copy the highlighted operation in the Undo/Redo Sidebar to a new image window; User can also drag the selected operation in the Undo/Redo Sidebar to the window area to create a new image window;
CC: Remove the highlighted operations from the Undo/Redo list (This button will be enabled only when the operation(s) is (are) selected, the opened image(the first operation) cannot be removed;
CD: Indicating the Current operation displayed in the image window;
CE: Operation Index; CF: Operation name.
DA: Layer Sidebar; DB: Make a New layer; DC: Remove a layer;
DD: Set as the Current layer; DE: Show/Hide a layer; DF: Rename a layer;
DG: Visibility control of the layer items;
DH: The Current active layer for operations;
DI: The layer Name. The image layer is always named as “Background”.

EA: Measurement Sidebar;
EB: The Appearance of the highlighted Object on the Current layer; you can edit the Appearance by clicking its item and editing it;
EC: The Calculation of the highlighted item on the Current layer;
ED: The Coordinate of the highlighted item on the Current layer; you can edit the Coordinate by clicking the item.

8.6.2 Sidebar>Camera
The Camera Sidebar is mainly used for the control of Toupcam camera, it includes 11 groups. Every group can be expanded by clicking the group name or the arrow button at the right of the group name.

Checking the Sidebar>Camera menu will activate/show it on the frame.

Please check Camera Sidebar in Sec.5 for details.

8.6.3 Sidebar>Folders
The Folders Sidebar is mainly used for the image Browse control.

Checking the View>Sidebar>Folders menu will activate/show the Folders Sidebar. Clicking its tree can navigate the file directories.
Double-clicking the directory in the Folders will create the Browse window. If there are image files under the tree that ToupView supports to browse, the image files will be displayed in Large or Small icons mode.

Their order can be set in Forward or Reverse format according to Sort by Name, Type, Size, Width or Height et al.

Clicking with the right mouse button on the directory will bring up the right mouse context menu as shown below:

This is the basic window explorer menu and will not explain it at here in this manual.

8.6.4 Sidebar>Undo/Redo

The Undo/Redo Sidebar is used to Undo/Redo operations for the Image and Process menus’ command.

Checking the View>Sidebar>Undo/Redo menu will activate/show the Undo/Redo Sidebar.

8.6.5 Sidebar>Layer

Layer Sidebar is used for the management of Layer operations. This operations including making a New Layer, Removing a Layer or Renaming a Layer and Layer visibility controlling et al.

Checking View>Sidebar> Layer will activate/show the Layer Sidebar.
8.6.6 Sidebar>Measurement
The Measurement Sidebar is used to check or edit the selected Layer Objects on the Layer.

Checking View>Sidebar>Measurement will activate/show the Measurement Sidebar.

In this sidebar, the Object Appearance, Calculation and Coordinates characteristic are listed. The Appearance and Coordinates can be edited.

8.7 Ruler and Grid
Ruler and Grid menu has 3 submenus, they are:

8.7.1 Grids>No Grids
Choosing this command will remove both Manual Grids and Auto Grids overlaid on the video/image window.

8.7.2 Grids>Manual Grids
Choosing this command will display two small Right Arrow and Down Arrow overlaid on the top of the Vertical Ruler and on the left of the Horizontal Ruler as shown below:

Move the mouse over the Down Arrow will show a horizontal drag icon. Drag the Down Arrow along the Horizontal Ruler to where ever you want. When it is dragging over the video/image, there will be a Vertical line appeared to let you judge where to
release this line on the video/image. You can drag any lines to overlay them on the video/image.

The overlaid lines can be adjusted by dragging the specific Down Arrow again on Horizontal Ruler.

Move the mouse over the Right Arrow will show a vertical drag icon. Drag the Right Arrow along the Horizontal Ruler to wherever you want. When it is dragging over the video/image, there will be a Horizontal line appeared to let you judge where to release this line on the video/image. You can drag any lines to overlay them on the video/image.

The overlaid lines can be adjusted by dragging the specific Right Arrow again on Vertical Ruler.

Choose the Grids>No Grid command to remove the Manual Grids overlaid on the video/image window. The menu will be checked.

Choose the Grids>Manual Grids command again (If it is unchecked) to display all the previous Manual Grids overlaid on the video/image window. The menu will be checked.

8.7.3 Grids>Auto Grids

Choose the Grids>Auto Grids command to overlay the grids on the video/image automatically.
The Auto Grids can be set in the Ruler and Grids>Setting menu.

8.7.4 Grids>Remove All Grids
Remove (Delete) all of the Manual Grids or Auto Grids overlaid on the image/video window.

8.7.5 Settings
Choosing the View>Ruler and Grid>Setting command, or choosing the Preference command and clicking the Rulers and Grids page realize the same function.

Choosing the Preference command and clicking the Rulers and Grids page can set Ruler Color, Cursor Color of the Horizontal Ruler and Vertical Ruler for the video or image windows. The Grid Style, Line Style, and Line Color for the Grid overlaid on the video and image window can also be set.

Ruler Color: The Horizontal Ruler color and Vertical Ruler color; Default is blue (0,0,255);

Cursor Color: The Cursor color; When you are moving your mouse over the video/image window, there will be Horizontal Cursor and Vertical Cursor move on the Horizontal Ruler and Vertical Ruler moving at the same time indicating the current Cursor position in both directions. Default is Red (255,0,0);

Grid Style: The Grid Style can be No Grid, Auto Grid or Manual Grid. Default is No Grid;
Grid Line Style: The Line Style for the grid can be Solid, Dash, Dot or DashDot et al. Default is Solid;

Grid Line Color: The color of the grid line. Default is Red (255,0,0).

8.8 Best Fit
Choose the View>Best Fit command to automatically resize the video/image to fit in the window.

Note: Choosing this command will enable View>Actual Size menu.

8.9 Actual Size
Note: This option will be disabled if the image is currently viewed at 100%. At any other zoom ratio, View>Actual Size will be enabled.

Choose the View>Actual Size command to set the active image to its Actual Size (e.g. 100%).

8.10 Track
Note: If the video/image size is smaller than the window size. The track operation will be disabled.

If the image's actual size is larger than the video/image window, check this command to position the video/image that does not fit entirely within in the video/image window. Its function is similar to the scroll bars. It is an alternative to using the arrows on the scroll bars for positioning the video/image within the window.

Checking the View>Track menu will change the cursor to and the button on the toolbar will be checked.

Then keep down the mouse button to drag the region of interest on the video/image to any location in the video/image window.

8.11 Properties
If an image file listed in the Browse window is highlighted. Choosing the View>Properties command or clicking the selected file in the Browse window with the right mouse button will bring up a Properties dialog as shown below:
The file Properties dialog including 4 pages. They are General, Security, Details and Previous Versions pages. These Property pages may depend on the operating system and we will not discuss it in this help manual.
9 Setup

9.1 Start/Pause

If the window is running, one can choose the Setup>Start/Pause command to pause the video and choose the Setup>Start/Pause command again to start the video.

9.2 Full Screen

Choosing the Setup>Full Screen command will display the video window in full screen style. Choosing the Setup>Full Screen command again will return to the default video window.

Note: The window should be in focus to make the Setup>Full Screen or ESC command enabled.

9.3 View Properties

The Setup>View Property command will help you to understand the camera statistical properties. Choose the Setup>View Property command to invoke the View Property dialog as below:

The items in the dialog are described in the following table:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device ID</td>
<td>Unique ID to identify the camera device.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Human readable string to identify the name of the camera device.</td>
</tr>
</tbody>
</table>
Still Image Capture: Whether or not the camera supports Still Image Capture. Still Image Capture is used for high resolution camera to capture an image with a different resolution from the video. This feature is mainly used to capture high resolution image under low resolution video to compromise the frame speed and the image resolution.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Width</td>
<td>The video window width.</td>
</tr>
<tr>
<td>Display Height</td>
<td>The video window height.</td>
</tr>
<tr>
<td>Video Width</td>
<td>The actual video window video width.</td>
</tr>
<tr>
<td>Video Height</td>
<td>The actual video window video height.</td>
</tr>
<tr>
<td>Compression</td>
<td>The compression format of the video stream.</td>
</tr>
<tr>
<td>Bits Per Pixel</td>
<td>Indicate how many bits are used to store on pixel.</td>
</tr>
<tr>
<td>Time (second)</td>
<td>Seconds elapsed since the video has been started.</td>
</tr>
<tr>
<td>Frame</td>
<td>Frames acquired since the video has been started.</td>
</tr>
<tr>
<td>Actual Frame Rate</td>
<td>Actual frame Rate of the video stream.</td>
</tr>
</tbody>
</table>

Note: The Actual Frame Rate is listed for reference. It varies depending on the computer's configuration. Different hardware configurations may have different Actual Frame Rates.

9.4 Video Overlay

9.4.1 Video Overlay: Overlay

Choose the Setup>Video Overlay command and click the Overlay page to overlay Scale, Magnification, Date and Clarity Factor on the video window.

This command will invoke Overlay page as above. The Position, Font Size, Font Weight of the Scale, Magnification and Date, and Clarity Factor can be defined.
Help Manual

together. Their Colors can be defined separately.

Clicking the OK button and the Scale, Magnification and Date, and Clarity Factor will be overlaid on the Video window. The Clarity Factor can tell if the sample is in good focused state. The larger the Clarity Factor, the better the sample focused.

**Note:** To enable the Scale bar, the Magnification must be defined and chosen first. The Unit can be any unit except Pixel. There are two methods to set the Unit, they are:

a) Choosing the Unit in the Unit dropdown combobox on the tool bar which is just on the left of the Magnification dropdown list box; b) Choosing the Option>Measurement••• command, a dialog called Measurement will bring up, click the Length Unit page and check the Unit in the Current to set the Unit.

9.4.2 Video Overlay: Marker•••

Choose the Video Overlay: Marker••• command to overlay Video Marker on the video window. The Video Marker type can be Cross, Rectangle, Circle, Cross+Rectangle, or Cross+Circle. The Video Marker is shown as below:

Choosing “Cross+Rectangle” in the Type combobox and Video Overlay: Marker dialog will become:
Edit the Cross Width and Cross Height, Rectangle Width and Rectangle Height, x Offset and y Offset, in their specific fields. Click Color to define the Video Marker color.

Click OK to end the Video Marker dialog and a Cross+Rectangle Marker will be overlaid on the video window as shown below:

Click Cancel to cancel the Video Overlay: Marker setup and return to the application area, or Apply to overlay the Marker on the video and keep the Video Overlay dialog there for further modification.

9.5 Video Watermark

Fig.1 shows a micro ruler. The dark lines can be extracted as Video Watermark and overlaid on the video window. The steps are:
1. Choose the **Capture>Capture Image** command or click ![Snap] to capture the micro ruler image as shown in Fig.1;

2. Choose the **Process>Binary** command to binarize the image as shown in Fig.2;

3. Choose the **Image>Adjust>Invert** command to invert the image and choose the **Image>Color Quantize** command to convert the image to 24 bits as in Fig.3. Choose the **File>Save As** command to save the image in 24 bit BMP format;

4. Choosing the **Setup>Video Watermark** command and a dialog called **Video Watermark** is brought up as shown in Fig.4. Click the ![Browse] button to locate the image saved in step 3. Use the defaults **Transparent (%)**. If everything is ok, click **OK** button. The final **Video Watermark** is overlaid on the video window as shown in Fig.5.
9.6 Move Watermark

9.6.1 Move to

If there is Watermark overlaid on the video window, this menu will be enabled.

Choosing the Setup>Watermark command will bring up a Move dialog. Where one can enter the X: and Y: offset value in their fields for the desired pixel move distances. The default X and Y offsets are 0;

9.6.2 Move to zero

If the Watermark was moved, this menu will be enabled. Choosing this menu will move the Video Watermark to its original coordinates (0, 0).

9.7 Rotate Watermark

9.7.1 Rotate to

If there is Watermark overlaid on the video, this menu will be enabled.

Choosing the Setup>Rotate Watermark>Rotate to command will bring up a Rotate dialog, where one can define an angle to Rotate the Video Watermark a specified angle around the video center (0, 0) (default value).
9.7.2 Rotate to zero

If the Video Watermark was rotated, the Rotate to zero menu will be enabled. Choosing this menu will rotate the Video Watermark to zero degree.

9.8 Gray Calibration

This function can make the image brightness a desired value among various scenarios in a specified area, achieving the continuity requirement of the observation. The Gray Calibration steps are summarized as follows:

1. Click the Exposure & Gain group name on the Camera Sidebar to expand the Exposure & Gain group, uncheck the Auto Exposure box (If it is checked).

2. Choose the Edit>Image Select command or click the Image Select button on the toolbar to select a reference region, and choose the Setup>Gray Calibration command. A dialog called Gray Calibration will be brought up to display the current ROI Average Gray. Now the brightness of the microscope can be adjusted until the Average Gray reaches to the desired value. Click “OK” to finish the calibration and return to the application area. The desired value here is around 200.
9.9 Video Source Property

This menu will be displayed and enabled only when the camera that supports DirectShow interface is started.

Choose the Setup>Video Source Property command to invoke the Video Source Property dialog:

The Video Source Property includes several categories such as Color, Exposure, Extended, Misc and ROI page etc. These pages are used for the control of your camera.

![Video Source Property dialog]

Note: Different camera may have different control contents. If you have any problems with these controls, try to contact your camera supplier to get the further technique help. ToupView has no responsibility to help you about these controls.

9.10 Video Stream Format

This menu will be displayed and enabled only when the camera that supports DirectShow interface is started.

The ToupView Video Stream Format configuration dialog is shown below:
One can change the video format mode, frame rate, color space, compression options and so on. Here, we only have the Video Size to check. Selecting the desired one and clicking OK. This will give you a selected Video Size for the new video window.

Click Cancel to cancel the selection and return to video window without any changes or Apply to apply the current selection to the video with the Properties remain opened.

Note: Different devices may have different user interfaces and items. Contact the camera supplier for details.

9.11 Still Image Options

Some cameras can capture a still image with its sizes different from the video stream. The camera may have a “pin” that acts as a hardware trigger, or it may support software triggering. A camera that supports still images capture will expose a still image pin to the designer.

To capture a still image, one should first set the size of the image to capture. The size is determined by the camera hardware. Here we show an example with UCMOS08000KPA camera.

Choosing the Setup>Still Image Options command will show the following Properties dialog:
It has 3264*2448, 1600*1200, and 800*600 resolutions. Select the desired one and press OK to accept the selection, or Cancel to ignore the current selection. Click Apply to apply the selection.

One can find if the device supports Still Image Capture or not by choosing the Setup>View Property command.

If the Still Image Capture's Value is Y in the View Property dialog, this means that the camera supports the Still Image Capture operation.
10 Capture

10.1 Capture Image F8

During the video preview, you can always choose the Capture>Image Capture command to capture the video image.

After the image is captured, the captured image will be the current active window. The Capture>Capture Image menu will be disabled. If you wish to capture image again, click the video window title to activate the video window and the Capture>Capture Image menu will be enabled again.

**Note:** a) The “Snap” button on the Camera Sidebar can continuously shoot the image even if the video window is not activated. Click this button on the Camera Sidebar to capture image quickly; b) Only when the video window is active, the Capture>Capture Image menu will be enabled; c) If the Live and Snap resolutions are different, ToupView need to switch the resolution from Live to Snap in the background to capture an image with Snap resolution. After the Snap is finished, ToupView will switch back to the Live resolution to continue the video stream process. Thus it will take more time to capture a still image.

10.2 Time-lapse (Auto Capture)•••

This function can capture a sequence of pictures with the same time interval; you can precisely set the time interval (2 to 3600 seconds) and the total number of images. Choosing the “Capture>Time-lapse (Auto Capture)•••” command will bring up Time-lapse (Auto Capture) dialog shown below:

**Directory:** The file Directory can be select by clickin the Browse button.

**File:** The File name including Name of Format, File Prefix, File type. It can be a combination of prefix, time and type and is shown in the Sample.

**Time Slot:** Time slot(Second,2-3600S) is a time segment to capture an image.

**Total Images:** Checking Total Images will enable its edit box. You can enter the Total Images (1-9999) to be captured. ToupView will stop the Time-lapse capture process automatically when the Total Images are reached.
If **Total Images** is unchecked, ToupView will capture the images continuously until you choose the **Capture>Stop Time-lapse (Auto capture)** command again to stop the **Time-lapse capture**.

![Image of ToupView Time-lapse settings]

Click **OK** to begin the **Time-lapse capture**, or **Cancel** to cancel the **Start Time-Lapse(Auto Capture)*** command.

After the **Time-lapse capture** is started, the **Capture>Start Time-Lapse (Auto Capture)*** menu will be changed to the **Capture>Stop Time-lapse (Auto capture)** menu. Choosing this command will stop the **Time-lapse capture**.

There are a variety of image format available (they are **bmp, jpg, png** and **tif**) to save the captured image. For example, when choosing **jpg** format, you can set the parameters of “**Option**” to adjust its compression quality or encoding method. Please check the **File>Save As** menu for details.

**10.3 Start Record***

1. You can a) choose the **Capture>Start Record*** command; b) click “**Record**” button on the **Camera Sidebar**; c) use the shortcut key “**F9**” to start recording movies. The video format can be **wmv/asf** (recommended) or **avi**;
2. Clicking **Next** on the **Video Format** dialog will bring up **Video File** dialog as below; Enter the video file name under **1. Set the name for the captured video file** field and click the **Browse...** button under **2 Select the directory for the video file** item to locate the video file directory. Click **Back** to return to the **Video Format** dialog, or **Next** to the next step;

3. An **Encoder** dialog will be brought up. Here you can select the **Encoder** format, set the **Bitrat** (Kbps) (256-16384), **Quality** (1-100) and **Key Frames Spacing** (1-30). Click **Back** to return to the **Video Format** dialog, or **Next** to the next step;
4. A dialog called Display Information will be brought up. Here you can enter Title, Author, Copyright and Description to their fields. Click Back to return to the Encoder dialog, or Next to the next step;

4. A dialog called Start to Capture will be brought up. Here you can check Time Limit (Minutes 1-1440) and enter recording time (If checked); Input Time-lapse(1-100). There is a Summary text to display what you have been defined. Click Back to return to the Encoder dialog, or Finish to end the setup;
5. After the Video capture is started. The button on the Camera Sidebar will become . Clicking will stop the capture process, otherwise it will stop until the Time Limit is reached. After the Video capture process is finished. The on the Camera Sidebar will become for the future Record process;

6. You can choose the File>Open Video command to display the captured video file in the video window;

7. Clicking on the video window with your right mouse button will bring up a context menu. It includes the View Properties menu to check the Video Properties, the Start/Pause menu to start or pause the video and the Full Screen menu to display the video in full screen mode. These commands can also be performed by choosing the Setup>Start/Pause, Setup>View Properties or Setup>Full Screen menu.

10.4 Start Broadcast
Start a network broadcasting service. Select the port and the video format before start the service. After that, ToupView will start broadcasting the video that is opened
by ToupView locally via the specified port and format. The other users could share the video by open broadcasting function.

Clicking the Next> button to set the video Encoder parameters for broadcasting. This set up dialog is just the same as those of video record process set up dialog. It mainly including Encoder, Encode Parameter such as Bitrate, Quality, Key Frame Spacing in second et al.

Clicking the Next> button again will invoke the Start to Broadcast dialog. Here, one can set the broadcast Time Limit in minutes. The Encoder parameters are also listed in the Summary window for reference.

Clicking the Finish button will start the broadcasting process and it will end up the process when it reaches to the Time Limit.
See File>Open Broadcast to understand the Start Broadcast function.
11 Image

11.1 Mode

11.1.1 Color Quantize

The Color Quantize command is widely used to change the image bit. ToupView supports the mutual changes among 24 bit, 8 bit, 4 bit or 1 bit images.

When the Colour Bits dialog is opened, the default checked color bit is the current image's color bit. Check the desired bit and click OK to end the command. The image will converted to the selected color bits in the image window.

11.1.2 Gray Scale

Choose the Gray Scale command to convert a color image (true color image or index color image) to a gray scale image. If the original image is 24 bit, the new image is 8 bit. Otherwise the bit of the image will not be modified.

11.2 Adjust

11.2.1 Curve

Choose the Image>Adjust>Curve command to adjust the entire tonal range of an image. But instead of making adjustments using only three variables (highlight, shadow, midtone), one can adjust any point on the curve along a 0-255 scale while keeping up to any other values constant. One can also use Curve to make precise adjustments for individual color channels on an image. The Curve dialog is shown below:

<p>| Horizontal | The horizontal axis of the graph represents the original intensity values of |</p>
<table>
<thead>
<tr>
<th><strong>Axis</strong></th>
<th>the pixels (<strong>Input</strong> levels).</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Vertical Axis</strong></td>
<td>The vertical axis represents the new color values (<strong>Output</strong> levels). In the default diagonal line, all of the pixels have identical <strong>Input</strong> and <strong>Output</strong> values.</td>
</tr>
<tr>
<td><strong>Curve area</strong></td>
<td>Area (specified with the <strong>blue rectangle</strong>) to setup a map between input and output; a) When you open the <strong>Curve</strong> dialog you see, perhaps surprisingly, not a curve but a straight line. As a default, the input values are the same as the output, so there’s no change; b) By clicking in the center of the line and dragging upwards, we make our first curve. Raising the curve increases the overall brightness of the scene. c) Conversely, clicking in the center and dragging downwards lowers the brightness, producing an image that’s darker overall; d) As well as clicking in the center, we can also adjust the endpoints. Clicking the top right point and dragging down limits the brightest part of the image, reducing contrast. e) If we drag that top right point to the left rather than down, we produce the opposite effect—increasing the contrast of the image. This is a very useful and controllable quick fix; f) By dragging the top and bottom points towards the center, we create a stylized, posterized effect that turns any photograph into more of a graphic object. g) Click once in the center of the RGB curve to &quot;pin&quot; that midpoint; now drag just the top half of the curve to make this S shape, and the result is to increase the overall contrast. h) You can add up to any control points to the curve, locking those values. To remove a control point, 1) drag it off the graph or 2) click the right mouse button on that point. You cannot delete the endpoints of the curve.</td>
</tr>
</tbody>
</table>
Help Manual

<table>
<thead>
<tr>
<th>Grid</th>
<th>Check to overlay the grid on the Curve window;</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Channel</strong></td>
<td>To adjust the color balance of the image, check the channel (R, G or B) from the Channel button. Check the white button to select RGB channels at the same time, which is located on the left of the R (Red), G (Green) and B (Blue) buttons;</td>
</tr>
<tr>
<td><strong>Curve</strong></td>
<td>Click the Curve with your left mouse button, a spline curve (straight line) will setup the initial input-output relation. Click on the Curve will mark the Curve with a point. The point number can be any as long as it can be inserted on the Curve. Drag the marked point until the image looks satisfactory. The point can be deleted by move the mouse on it and click the right mouse button on it.</td>
</tr>
<tr>
<td><strong>Pencil</strong></td>
<td>Check the pencil button at the bottom of the dialog, and use your left mouse button to draw a new arbitrary Curve in the Curve area.</td>
</tr>
<tr>
<td><strong>Reset</strong></td>
<td>Click the Reset button will reset the Curve to the initial straight line.</td>
</tr>
<tr>
<td><strong>Apply</strong></td>
<td>Apply current Curve map on the image.</td>
</tr>
</tbody>
</table>

11.2.2 Auto Level

The Image>Adjustment>Auto Level command moves the level's sliders automatically to set highlight and shadow. It defines the lightest and darkest pixels in each color channel as white and black and then redistributes the pixels' color values proportionately. Since Auto Level adjusts each color channel individually, it
may remove or introduce color casts. The Auto Level command moves the level's sliders automatically to set highlight and shadow. It defines the lightest and darkest pixels in each color channel as white and black and then redistributes the pixels' color values proportionately. Since Auto Level adjusts each color channel individually, it may remove or introduce color casts.

By default, this feature clips the white and black pixels by 0.5%—that is, it ignores 0.5% of the lightest pixels and 0.5% of the darkest pixels when identifying the lightest and darkest pixels on the image. Choose the Options>Auto Correction menu command to modify this default setting. This ensures that white and black values are representative without being determined by extreme pixel values. The Auto>Correction dialog is shown below:

![Auto Range dialog](image)

The Image>Adjustment>Auto Level command gives good results when an image with an average distribution of pixel values needs a simple contrast adjustment or when an image has an overall color cast. However, adjusting the Curves manually is more precise.

See Image>Adjustment>Auto Contrast for another auto adjust command.

### 11.2.3 Auto Contrast

The Image>Adjustment>Auto Contrast command automatically adjusts the overall contrast and mixture of colors in an RGB image. Since it does not adjust channels individually, Auto Contrast does not introduce or remove color casts. It maps the lightest and darkest pixels in the image to white and black, which makes highlights appear lighter and shadows appear darker.

When identifying the lightest and darkest pixels on an image, Auto Contrast clips the white and black pixels by 0.5%—that is, it ignores the first 0.5% of either extreme.

Choose the Options>Auto Correction menu to modify this default setting. This
ensures that white and black values are representative without being determined by extreme pixel values. The **Auto Correction** dialog is shown below:

The **Auto Contrast** command can improve the appearance of many photographic or continuous-tone images. It does not improve flat-color images.

See **Image>Adjustment>Auto Level** for another auto operation.

**11.2.4 Histogram Equalization**

Histogram Equalization is a kind of histogram process. The histogram can reflect the statistical information for the R, G, and B of the pixels of the original image. The algorithm calculates each separately, equalizes the R, G, and B of the points linearly, and reassign them.

**11.2.5 Brightness/Contrast**

The **Image>Adjustment>Brightness/Contrast** command offers simple adjustments to the tonal range of an image. This command makes the same adjustment to every pixel in the image. The Brightness/Contrast command does not work with individual channels and is not recommended for high-end output because it can result in the loss of details about the image.

**Preview**: Check this button to display real-time effects when drags the slider bar. Default is checked.

**Brightness**: Dragging the slider bar to the left decreases the level and dragging it to the right increases the level. The numbers on the right of the slider bar displays the Brightness value. Values can range from -100 to +100. Default is 0;
**Help Manual**

**Contrast:** Dragging the slider bar to the left decreases the level and dragging it to the right increases the level. The numbers on the right of the slider bar displays the Contrast value. Values can range from -100 to +100. Default is 0;

### 11.2.6 Color

Choose the **Image>Adjustment>Color** command to modify the overall mixture of the colors in an image.

There are four color modules:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RGB</strong></td>
<td>ToupView uses the <strong>RGB</strong> model. It assigns an intensity value to each pixel ranging from 0 (black) to 255 (white) for each of the RGB components in a color image. For example, a bright red color might have an R value of 246, a G value of 20, and a B value of 50. When the values of all three components are equal, the result is a shade of neutral gray. When the value of all components is 255, the result is pure white; when the value is 0, pure black. <strong>RGB</strong> images use three channels to reproduce up to 16.7 million colors on-screen. In addition to being the default mode for new ToupView images, the <strong>RGB</strong> mode is used by computer monitors to display colors. This means that when working in color modes other than <strong>RGB</strong>, such as <strong>CMYK</strong>, ToupView uses <strong>RGB</strong> mode for display on-screen. Although <strong>RGB</strong> is a standard color mode, the exact range of colors represented can vary, depending on the application or display device.</td>
</tr>
<tr>
<td><strong>CMYK</strong></td>
<td>The <strong>CMYK</strong> mode is based on the light-absorbing quality of ink printed on papers. As white light strikes translucent inks, certain visible wavelengths are absorbed while others are reflected back to the eyes. In theory, pure cyan (<strong>C</strong>), magenta (<strong>M</strong>), and yellow (<strong>Y</strong>) pigments should combine to absorb all light and produce black. For this reason these colors are called subtractive colors. Because all printing inks contain some impurities, these three inks actually produce a muddy brown and must be combined with black (<strong>K</strong>) ink to produce a true black. (<strong>K</strong> is used instead of <strong>B</strong> to avoid confusion with blue.) Combining these inks to reproduce color is called four-color process printing.</td>
</tr>
</tbody>
</table>
**Help Manual**

<table>
<thead>
<tr>
<th>HSI</th>
<th>The subtractive (CMY) and additive (RGB) colors are complementary colors. Each pair of subtractive colors creates an additive color, and vice versa.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Based on the human perception of color, the HSI model describes three fundamental characteristics of colors:</td>
</tr>
<tr>
<td></td>
<td><strong>Hue</strong> is the color reflected from or transmitted through an object. It is measured as a location on the standard color wheel, expressed as a degree between 0° and 360°. In common use, <strong>Hue</strong> is identified by the name of the color such as red, orange, or green.</td>
</tr>
<tr>
<td></td>
<td><strong>Saturation</strong>, sometimes called chroma, is the strength or purity of the color. <strong>Saturation</strong> represents the amount of gray in proportion to the hue, measured as a percentage from 0% (gray) to 100% (fully saturated). On the standard color wheel, <strong>Saturation</strong> increases from the center to the edge.</td>
</tr>
<tr>
<td></td>
<td><strong>Intensity</strong> is the relative lightness or darkness of the color, usually measured as a percentage from 0% (black) to 100% (white).</td>
</tr>
<tr>
<td>HLS</td>
<td>The HLS model is very similar to the HSI color model. The main difference between them is the calculation used to produce the brightness value. In the HLS model, a pixel's brightness (L) is derived from its three (R, G and B) color values. In the HLS model, a pixel's brightness (L) is determined by the minimum and maximum values of its three color values.</td>
</tr>
</tbody>
</table>

**Preview**: Check this button to display the real-time effect when the slider bar's position is modified.

The values beside the slider bar show the color changes in various color channels.

For **RGB** channel values, they can range from -100 to +100. Default is 0;

For **CMYK** channel values, they can range from -100 to +100. Default is 0;

For **HSI** channel values, the **H** value can range from -180 to 180, the **S** value can
range from 
-275 to 275, and the I value can range from 
-442 to 442. Default is 0;

For HLS channel values, the H value can range from 
-180 to 180, the L value can range from 
-100 to 100, and the S value can range from 
-100 to 100. Default is 0;

11.2.7 HMS

Choose the Image>Adjustment>HMS command to adjust the HL (Highlight), M (Midtone), and S(Shadow) parts of the image. Each part's value ranges from 
-100 to 100. This command is only available for 24 bits true color image.

Preview: Check this button to display the real-time effect when one changes the slider bar's position. Default is checked.

11.2.8 Gamma

The Image>Adjustment>Gamma measures the brightness of midtone values produced by a device (often a monitor). A higher gamma value yields an overall darker image.

Preview: Check this button to display the real-time effects when one changes the slider bar’s position. Default is checked;

Gamma: Dragging the slider bar to the left decreases the level, while moving it to the right increases the level. Values can range from 0 to 3.0. Default is 1.0.

11.2.9 Filter Color

Choose the Image>Adjustment>Filter Color command to filter a special color channel from a color image. Check either Red, or Green, or Blue color to filter. For every pixel, if check Red color to filter, only information about the red channel will be
discarded, and Green and Blue information will remain there.

See Extract Color••• for another color operation.

11.2.10 Extract Color•••
Choose the Image>Adjustment>Extract Color••• command to extract a special color channel from a color image. Check either Red or Green, or Blue color to extract.

For every pixel, if selecting Red color to extract, only information about the red channel will be kept, and Green and Blue information will be discarded.

See Filter Color••• for another color operation.

11.2.11 Invert
Choose the Image>Adjustment>Invert command to reverse the pixel values of the active image without going through the lookup table.

11.3 Rotate
Choose the Image>Rotate command to rotate the entire image. One has the following submenus:

11.3.1 90(CW)
Rotate the image clockwise by a quarter-turn.

11.3.2 180(CW)
Rotate the image clockwise by 180 degrees.

11.3.3 270(CW)
Rotate the image clockwise by 270 degrees.

11.3.4 Arbitrary

Rotate the image by a specified angle. If choosing this option, enter an angle between 0 and 360 degrees in the angle text box, and check CW or CCW to rotate clockwise or counterclockwise. For the Arbitrary operation, it will invoke an Image Rotate dialog like below:

![Image Rotate Dialog]

**Degree**: The degree that the image to be rotated.

**CW**: Rotates the image clockwise.

**CCW**: Rotates the image counterclockwise.

**Quality**: One can select one of the three methods for the image rotation among Nearest Neighbor, Bilinear, and Bicubic. The default is Bilinear.

11.3.5 Flip Horizontal

Reverses the image in the application area so that the top right corner of the original image is now the top left, and the top left corner of the original image is now the top right corner.

11.3.6 Flip Vertical

Reverses the image in the application area so that the top right corner of the original image is now the bottom right corner, and the top left corner of the original image is now the bottom left corner.

11.4 Crop Shift+C

Choose the Image>Crop command to remove the portions of an image that does not want so that the focus is on the part of the image that is left. This document instructs users on how to Crop an image in ToupView.

Crop Demo
1. Choose the **Open Image** command to open an image to **Crop**;

2. Choose the **Edit > Image Select** command or click the **Image Select** button on the **Toolbar**, the cursor will change to a small cross.

3. Move the cursor over the image to the desired location, click the mouse button and hold it down to mark the first position.

4. Drag the mouse over the part of the image to be kept, a dotted rectangle appears around the selection and release the left mouse button.

5. **Optional 1**: To move the rectangle: a) Move the mouse over the selected area and when it becomes a move cursor, click and hold the left mouse button; b) Drag the selected area to the desired position.

![Image Selection](image-selection.png)

6. **Optional 2**: To change the size of the rectangle: a) Put the mouse cursor on one of the handles that appear on the edges of the selected area; b) Click and hold the mouse button; c) Drag the box to the desired size.

**Note**: Each of the handles that appear on the edges of the box sizes the box differently.

7. To **Crop** the image, choose the **Image > Crop** command or press **Shift+C** buttons.

**Note**: If the selected area is on the video, choosing the **Image > Crop** command will capture the selected area and display it on a new image window.

**11.5 Image Scale**

Choose the **Image > Image Scale** command to change the image to a specified size. This process actually changes spatial resolution by adding (replicating) or removing (decimating) pixels to achieve the specified dimensions.
Width and Height: When choosing the Image Scale command; the dialog displays the dimensions of the original image in pixels. The Width and the Height can be set on the new image by adding or removing pixels. If Constrain Proportions is checked, the Width and Height will stay proportionate to each other. If Constrain Proportions is unchecked, the Width and the Height can set independently, but this will distort the image.

Reset: Reset the image Width and Height to the original ones.

Constrain Proportions: To maintain the current proportions of pixel Width and Height, check Constrain Proportions. This option automatically updates the Width as the Height is modified, and vice versa. Otherwise, uncheck the Constrain Proportions button.

Scale method: There are 3 options for the Scale method. They are: Nearest Neighbor, Bilinear, and Bicubic. The default is Bilinear.

11.6 Histogram

A Histogram illustrates how pixels in an image are distributed by graphing the number of pixels at each color intensity level. The Histogram shows whether the image contains enough detail in the Shadows (shown in the left part of the Histogram), Midtones (shown in the middle), and Highlights (shown in the right part) in order to make a good correction.

The Histogram also gives a quick picture of the tonal range of the image, or the image key type. A low-key image has detail concentrated in the shadows, a high-key image has detail concentrated in the highlights, and an average-key image has detail concentrated in the Midtones. An image with a full tonal range has a number of pixels in all areas. Identifying the tonal range helps determine the appropriate tonal corrections.
Choose the Image>Histogram command to open the Histogram dialog as shown below.

Depending on the image’s color mode, choose R, G and B, or Luminosity to view a composite Histogram of all the channels.

If the image is RGB true color, choose Luminosity to display a Histogram representing the luminance or intensity values of the composite channel.

If the image is RGB true color, choose R, G and B to display a composite Histogram of the individual color channels in color.

Do one of the following:

To view information about a specific pixel value, place the mouse pointer in the Histogram.

To view information about a range of values, click down the left mouse button and drag it in the Histogram to highlight the range.

The dialog displays the following statistical information below the Histogram:

**Pixels**: Represents the total number of pixels used to calculate the Histogram.
Help Manual

**Level**: Displays the intensity level of the area underneath the pointer.

**Count**:Shows the total number of pixels corresponding to the intensity level underneath the pointer.

**Percentile**: Displays the cumulative number of pixels at or below the level underneath the pointer. This value is expressed as a percentage of all of the pixels in the image, from 0% at the far left to 100% at the far right.

11.7 Resolution

Choose the Image>Resolution command to set the image Resolution to calibrate the spatial scale. By default, ToupView expresses spatial measurements in terms of pixels. This Resolution command is used to change the terms in which ToupView reports such measurements. This command should be run first in order to measure objects in terms of units other than pixels.

![Resolution setting](image)

**X**: Horizontal PPM (Pixels per meter) of current Resolution.

**Y**: Vertical PPM (Pixels per meter) of current Resolution.

**Note**: The resolution in the Y direction need not to be filled. ToupView will always let it equal to the X direction.

After the new Resolution is set, all of the measurements will be calculated according to the new Resolution. (See more in the Measurements and Options>Measurement menu).
12 Process

12.1 Filter Shift+F

Choose the Process>Filter command to apply one of ToupView's numerous filters on the active image. If you are not familiar with the process and effects of filtering, some discussions about spatial filtering should be reviewed. ToupView provides an extensive set of convolution and no convolution (morphological) filters. You can also create custom filter kernels and apply them with the Filter commands.

Choosing the Process>Filter command will open the Filter dialog. Each group of filters has its own property page or tab, where the Filter type and size can be selected. The filtered results are almost always written to the active image. The Edit>Undo command can be used to remove Filter operations that have been applied.

12.1.1 Image Enhance

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low Pass</td>
<td>Check this filter to soften an image by eliminating high-frequency information (this has the effect of blurring sharp edges). The Low Pass filter replaces the center pixel with the mean value in its neighborhood. The Low Pass filter can also be used to remove noise.</td>
</tr>
<tr>
<td>High Pass</td>
<td>Check this filter to enhance high-frequency information. The High Pass filter replaces the center pixel with a convolved value that significantly increases its contrast from its neighbors. The High Pass filter leaves only elements of high contrast.</td>
</tr>
<tr>
<td>Gauss</td>
<td>Check this filter to soften an image by eliminating high-frequency information using a Gauss function. This has the effect of blurring sharp edges. The operation of the Gauss filter is similar to the Low Pass filter, but</td>
</tr>
<tr>
<td>Filter</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>High Gauss</td>
<td>Check this filter to enhance fine details. This operation is similar to the unsharp masking technique (see the Sharpen filter), but it introduces less noise into the image. It uses a Gaussian curve type of kernel. Available in 7x7 and 9x9 kernel sizes.</td>
</tr>
<tr>
<td>Equalization</td>
<td>This filter is used to enhance the contrast based on the histogram of the local neighborhood (See Option below).</td>
</tr>
<tr>
<td>Sharpness</td>
<td>Check this filter to enhance fine details, or refocus an image that is blurred. The sharpen filter sharpens the image using the unsharp masking technique.</td>
</tr>
<tr>
<td>Median</td>
<td>Check this filter to remove impulse noise from an image. The Median filter replaces the center pixel with the Median value in its neighborhood. It will also blur the image.</td>
</tr>
<tr>
<td>Rank</td>
<td>Check this filter to remove impulse noise from an image. The pixels in the kernel are ranked by order of intensity, and the pixel in that range at the rank percentage is chosen for comparison. For example, in a 5x5 kernel, there are 25 pixels. A rank percentage of 95% would choose second-brightest pixel for comparison. If the difference between the selected pixel and the center pixel is greater than the threshold value, the Rank filter replaces the value of the center pixel with the value of the selected pixel.</td>
</tr>
</tbody>
</table>

Option

1. If one of the Enhancement filters is checked, the following options will be displayed:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 x 3</td>
<td>Check 3 x 3 kernel will produce a more subtle filtering effect.</td>
</tr>
<tr>
<td>5 x 5</td>
<td>Check 5 x 5 kernel will produce a moderate filtering effect.</td>
</tr>
<tr>
<td>7 x 7</td>
<td>Check 7 x 7 kernel will produces a more extreme filtering effect.</td>
</tr>
<tr>
<td>Passes</td>
<td>Set the filter applied times on the image. When a filter is applied multiple times, its effect is amplified by each pass. An image that has been softened by one pass of the Low Pass filter will be softened further by a second pass.</td>
</tr>
<tr>
<td>Strength</td>
<td>Enter an applied value from 1-10 that reflects how much of the filtering effect is applied.</td>
</tr>
</tbody>
</table>
Help Manual

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effect on the image.</td>
<td>A value of 10 specifies the full strength (100%) of the filtered result applied to each pixel. Values less than 10 cut the full weight of the filter. A value of 1 indicates that only 10% of the difference between the filtered pixel value and the original pixel value should be applied, a value of 2 indicates that 20% of the difference should be applied, and so forth.</td>
</tr>
<tr>
<td>Rank</td>
<td>This value specifies which pixel in the sorted array will be used to replace the center pixel. Pixels in the array will be sorted in ascending order. The pixels are indexed from 0 to Kernel Size x Kernel Size-1. In the pixel index 0 corresponds to the lowest pixel value. The Rank will be specified in terms of a percentage of the indexes (Kernel Size x Kernel Size-1). A 50% Rank means the middle of the array. 0% rank means the lowest index (lowest gray value), and 100% rank means the highest index (highest gray value).</td>
</tr>
</tbody>
</table>

2. If the Equalization filter is checked, the options will relate to the histogram equalization. Local Histogram Equalization modifies the contrast of an image based on the pixel values in a small window surrounding each pixel.

| Window | Image pixels statistics (min, max, histogram, mean, standard deviation, etc.) will be calculated on a small Window of the image. These measurements are then used to derive the local contrast for that area of the image. In short, an area of Window x Window around each pixel is all that is considered when modifying the intensities in the image. Larger Window produces smoother results, while small Window track small details more closely. |
| Best Fit | Choose the Best Fit button to optimize the values for the particular image. The results are achieved by stretching the local histogram to maximize the contrast between the brightest and darkest pixels in the local window region. |
| Linear | This option distributes the histogram linearly across the intensity scale. This function produces a high contrast image with the highest possible dynamic range. |
| Logarith | This option concentrates the histogram at the low end of the scale. This |
### 12.1.2 Edge Enhance

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sobel</td>
<td>Check this filter to enhance just the principal edges in an image. The Sobel applies a mathematical formula to a 3x3 neighborhood to locate and highlight its edges.</td>
</tr>
<tr>
<td>Roberts</td>
<td>Check this filter to enhance fine edges in an image. The Roberts filter is not a convolution filter. It applies a mathematical formula upon a 4 x 4 neighborhood to produce its effect. The upper left pixel in the neighborhood is the one that is replaced.</td>
</tr>
<tr>
<td>Sculpt</td>
<td>Check this filter to apply a sculpted effect on the image.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>Check this filter to detect and emphasize horizontal edges.</td>
</tr>
<tr>
<td>Vertical</td>
<td>Check this filter to detect and emphasize vertical edges.</td>
</tr>
</tbody>
</table>

### Options

1. If one of the Edge filters has been checked, the options will relate to kernel size and filtering strength. The following options will be displayed:

| 3 x 3       | Check 3x3 kernels to produce a more subtle filtering effect.               |
### Help Manual

| 5 x 5 | Check 5x5 kernels to produce a moderate filtering effect. |
| 7 x 7 | Check 7x7 kernels to produce a more extreme filtering effect. |
| **Passes** | Enter the number of times that the filter will be applied to the image. When a filter is applied multiple times, its effect is amplified by each pass. An image that has been softened by one pass of the Image Enhancement Filter, will be softened further by a second pass. |
| **Strength** | Enter a value from 1-10 that reflects how much of the filtering effect to apply to the image. A value of 10 specifies that the full strength (100%) of the filtered result will be applied to each pixel. Values less than 10 cut the full weight of the filter - a value of 1 indicates that only 10% of the difference between the filtered pixel value and the original pixel value should be applied, a value of 2 indicates that 20% of the difference should be applied, and so forth. |

2. If **Sobel** or **Roberts** is checked, no options are available.

#### 12.1.3 Morphological

<p>| <strong>Erode</strong> | Check this morphological filter if one wants to modify the size of objects in the image. The Erode filter erodes the edges of bright objects and enlarges the edges of dark ones. |
| <strong>Dilate</strong> | Check this morphological filter if one wants to modify the size of objects in the image. The Dilation filter dilates bright objects and erodes dark ones. |
| <strong>Open</strong> | Check this morphological filter if one wants to modify the shape of objects in the image. Assuming the image contains bright objects on a dark field, |</p>
<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>The Open filter will smooth object contours, separate narrowly connected objects, and remove small dark holes.</td>
</tr>
<tr>
<td>Close</td>
<td>Check this morphological filter if one wants to modify the shape of the objects in the image. Assuming the image contains bright objects on a dark field; the Close filter will fill gaps and enlarge protrusions to connect objects that are close together.</td>
</tr>
<tr>
<td>Tophat</td>
<td>Check this filter to detect and emphasize points, or grains, that are brighter than the background. There are 3 kernel sizes for this processing. Click the radio button to change the kernel size to the value that most closely matches the size of the grains to detect.</td>
</tr>
<tr>
<td>Well</td>
<td>Check this filter to detect and emphasize points, or grains, that are darker than the background. There are 3 kernel sizes for this processing. Click the radio button to change the kernel size to the value that most closely matches the size of the grains to detect.</td>
</tr>
<tr>
<td>Gradient</td>
<td>Check this filter to enhance edges in an image.</td>
</tr>
<tr>
<td>Watershed</td>
<td>Check this filter to separate objects that are touching. The Watershed filter erodes objects until they disappear, then dilates them again, but will not allow them to touch. The Watershed filter will not operate upon True Color images. If one wants to separate objects in a True Color image, he must first convert it to Gray Scale (see Process Frame: Image&gt;Gray Scale).</td>
</tr>
<tr>
<td>Thinning</td>
<td>Check this filter to reduce an image to its skeleton. When choosing this filter, one must set the threshold that determines whether a pixel is part of the subject or part of the background (see Options below). The Thinning filter will not operate upon True Color images. If one wants to thin a True Color image, he must first convert it to Gray Scale.</td>
</tr>
<tr>
<td>Distance</td>
<td>The distance filter is used to show the distances of pixels within blobs to the outer boundaries of those blobs. After applying the distance filter, the background will be black (i.e. pixels with value 0). Only the area within the blobs will have non-zero values (will be white). The values of each pixel within the blob will be a count of the shortest distance from that pixel to the edge of the blob. Thus, all pixels along the blob's border will have a value of 1 (since they are one pixel away from the edge of the blob); pixels that are a distance of 2 from the border will have the value 2, and so on.</td>
</tr>
</tbody>
</table>
This creates a distance map of the image. The **Distance** filter will not operate upon **True Color** images. If one wants to use the **Distance** filter with a **True Color** image, he must first convert it to **Gray Scale**.

**Options**

1. If **Erode**, **Dilate**, **Open**, or **Close** filters is checked, the options will relate to the kernel size and shape. The following options will be presented:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 x 2 Square</td>
<td>Check to use the 2x2 square kernel configurations.</td>
</tr>
<tr>
<td>3 x 1 Row</td>
<td>Check to use the 3x1 row kernel configuration.</td>
</tr>
<tr>
<td>1 x 3 Column</td>
<td>Check to use the 1x3 column kernel configuration.</td>
</tr>
<tr>
<td>3 x 3 Cross</td>
<td>Check to use the 3x3 cross kernel configuration.</td>
</tr>
<tr>
<td>5 x 5 Circle</td>
<td>Check to use the 5x5 circular kernel configurations.</td>
</tr>
<tr>
<td>7 x 7 Circle</td>
<td>Check to use the 7x7 circular kernel configurations. This is a two-pass filter, accomplished using a 5 x 5 circle followed by a 3x3 cross.</td>
</tr>
<tr>
<td>11 x 11 Circle</td>
<td>Check to use the 11 x 11 circular kernel configurations. This is a three-pass filter, accomplished using a 5 x 5 circle followed by another 5 x 5 circle, followed by a 3 x 3 cross.</td>
</tr>
</tbody>
</table>

**Passes**

Set the number of times iterate the filter.

**Note**: The circular kernels are especially effective on round objects (cells, grains and so on) because their circular configuration preserves the circular shape of the objects better than square configurations.

2. If the **Tophat**, **Well**, or **Gradient** filter is selected, the options will relate to kernel size and shape. The following options will be presented:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 x 3</td>
<td>Check to use the 3x3 square kernel configurations.</td>
</tr>
<tr>
<td>5 x 5</td>
<td>Check to use the 5x5 square kernel configurations.</td>
</tr>
<tr>
<td>7 x 7</td>
<td>Check to use the 7x7 square kernel configurations.</td>
</tr>
</tbody>
</table>

3. If **Watershed**, **Thinning**, or **Distance** filter is checked, the options will relate to the threshold. The following option will be presented:

**Threshold**

Enter a percentage value from 1-100 that specifies the intensity value to binarize the image. For example, a **Threshold** of 50% on a **Gray Scale**
image would set all values ≤127 to 0 (black) and all values ≥128 to the maximum value for that image class (white).

12.1.4 Kernel

The Kernel page allows edit the kernel files for the morphological and convolution filters.

Note: The HiPass, LowPass, Laplacian and Unsharp kernel files are used by the HiPass, LowPass, Laplacian, and Sharpen options listed in the Image Enhancement Filters page dialog window (i.e. there is no difference between selecting one of these kernel files and selecting its Option button in the Filter window -- the two methods ultimately do the same thing). Because these kernel files are essential to the operation of these filtering options, they must not be deleted or renamed.

<table>
<thead>
<tr>
<th>Filter type</th>
<th>Check to modify the kernel for a selected Filter type, either Convolution or Morphological filters.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit•••</td>
<td>Check to modify the selected filter kernel using the Edit Kernel dialog.</td>
</tr>
<tr>
<td>Name•••</td>
<td>This combobox contains the name of the selected kernel file. If one wants to save the modified kernel file to the same file, leave it as it is. If one wants to save the file to a new location, enter the new filename here.</td>
</tr>
<tr>
<td>Kernel Size</td>
<td>Click the spin buttons or enter the number to change the size of the kernel. Either direction may take into account one to nine pixels. As one modifies the Kernel Size, the shape of the kernel representation changes accordingly.</td>
</tr>
<tr>
<td>Help Manual</td>
<td></td>
</tr>
<tr>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>the center of the dialog, there are white boxes containing coefficients that will be multiplied with each pixel that will be taken into account by the filter kernel. One can change any coefficient by clicking on it and adjust it as desired.</td>
<td></td>
</tr>
<tr>
<td>Fill</td>
<td></td>
</tr>
<tr>
<td>Click this button to fill every element of the kernel with a particular value. The Fill kernel dialog appears. One may enter a value between 0 and 10. Using the Fill button is useful for setting all coefficients to the same value. One may then change the coefficients that require a different value.</td>
<td></td>
</tr>
<tr>
<td>Offset</td>
<td></td>
</tr>
<tr>
<td>The pixel whose value is being modified is usually the center-most pixel. One may, however, designate any pixel. ToupView signals the pixel to be changed by putting a box around it. Choose the X and Y Offset spin buttons to apply</td>
<td></td>
</tr>
<tr>
<td>New•••</td>
<td></td>
</tr>
<tr>
<td>Click to create a new filter kernel. The Edit Kernel dialog will appear. The functions of the dialog are the same way as the dialog for Edit••• described above), with the exception that the file name for the new kernel file must be provided.</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td></td>
</tr>
<tr>
<td>Click to delete the selected filter kernel file.</td>
<td></td>
</tr>
<tr>
<td>Options</td>
<td></td>
</tr>
<tr>
<td>The choices in this group box will vary depending upon the kind of selected filter.</td>
<td></td>
</tr>
</tbody>
</table>

**12.2 Stitch**

**12.2.1 Video Stitch**

When the video window is active, choosing the Process>Stitch command will invoke the video Stitch dialog as below:

<table>
<thead>
<tr>
<th>Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>The image stitching direction. Horizontal or Vertical; The default is Horizontal;</td>
</tr>
</tbody>
</table>
Run | The stitching run method: Background or Foreground. The default is Background.
---|---
Snap: | The captured images from the camera;
Snap | Click to capture image from camera;
Reset | When an image or images is or are captured, the Reset button will be enabled, click Reset will remove it or them from the memory; It will be disabled when there is no captured image;
OK | Click Ok to begin image stitching. This button will be enabled only when the snapped images are more than 2;
Cancel | Click to cancel the stitching process;

In the stitched image, there are some black areas. These are happened when there are translations between the images in both directions.

12.2.2 Image Stitch

When the image window is active, choosing the Process>Stitch command will invoke the image Stitch dialog

Available Images | The images opened by ToupView:
### Help Manual

<table>
<thead>
<tr>
<th><strong>Selected Images</strong></th>
<th>The images selected for stitching;</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add&gt;&gt;</strong></td>
<td>When an image or images is or are selected and highlighted in the <strong>Available Images</strong> window, the <strong>Add&gt;&gt;</strong> will be enable. Click <strong>Add&gt;&gt;</strong> will add it or them into the <strong>Selected Images</strong> window;</td>
</tr>
<tr>
<td><strong>Add All&gt;&gt;</strong></td>
<td>Click <strong>Add All&gt;&gt;</strong> will add all of the <strong>Available Images</strong> into the <strong>Selected Images</strong> window;</td>
</tr>
<tr>
<td><strong>Remove</strong></td>
<td>When an image or images is or are selected and highlighted in the <strong>Selected Images</strong> window, the <strong>Remove</strong> button will be enabled, click <strong>Remove</strong> will remove it or them from the <strong>Selected Images</strong> window;</td>
</tr>
<tr>
<td><strong>Clear</strong></td>
<td>Used to clear all of the images in the <strong>Selected Images</strong> window. When no image in the <strong>Selected Images</strong> window, it will be disabled;</td>
</tr>
<tr>
<td><strong>Direction</strong></td>
<td>The image stitching direction. <strong>Horizontal</strong> or <strong>Vertical</strong>: The default is <strong>Horizontal</strong>;</td>
</tr>
<tr>
<td><strong>Run</strong></td>
<td>The stitching run method: <strong>Background</strong> or <strong>Foreground</strong> method. The default is <strong>Background</strong>;</td>
</tr>
<tr>
<td><strong>OK</strong></td>
<td>Click <strong>Ok</strong> to begin image stitching. Only the <strong>Selected Images</strong> are more than 2, this button will be enable;</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Click to cancel the stitching process;</td>
</tr>
</tbody>
</table>

4 images for stitching
Stitching finished image

In the stitched image, there are some black areas; these are happened when there are translations between the images in both directions.

12.2.3 Browse Window Stitch

Clicking the Folders Sidebar to activate it. Double-clicking the right directory to show the images under the directory in the Browse window. Choosing the image files to be stitched and then clicking the right mouse button will display the context menu, choosing the Stitch submenu to start the image stitch process(One can also choosing Process>Stitch to do the same operation after the files are selected in the Browse window)
After the Stitch command is selected, a dialog called Stitch will popup. Choosing the right direction and clicking OK to begin the stitching.

The final stitched image will look like below

12.3 EDF••• Shift+E

12.3.1 Browse Window EDF
Clicking the Folders Sidebar to activate the Browse Window. Double-clicking the directory to display the images in the Browse window in Icon mode. Choosing the image files to be fused with Ctrl+A (Select all in the current directory) or Ctrl+left mouse button to select the image one by one) and then clicking the right mouse button will display a context menu, choosing the EDF submenu to start the image fusion process (One can also choose Process>EDF command to do the same operation after the image files are selected in the Browse window).
After the EDF command is chosen, a dialog called Select Method is pop up as follows:

There are 3 EDF methods in ToupView, they are:

<table>
<thead>
<tr>
<th>Maximum Contrast</th>
<th>Maximum Contrast method is similar with weighted average method, and the input images must be in Z order as well. The difference is that the maximum contrast method may lose some detail however the preserved details will be sharper.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Maximum Contrast method is a preferred method in these 3</td>
</tr>
</tbody>
</table>
Help Manual

<table>
<thead>
<tr>
<th>EDF methods.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weighted Average</td>
</tr>
<tr>
<td>FFDSSD</td>
</tr>
</tbody>
</table>

12.3.1.1 Maximum Contrast

Choosing Maximum Contrast in the Select Method dialog will pop up an Options Dialog as follows:

![Options Dialog](image)

**Detail Clarity** affects the fine detail of the result. Default: 107, Range: 10~240;

**Total Brightness** is the overall brightness. The Detail Clarity and Background Brightness will result in the change of the Total Brightness. For that reason, the Total Brightness may
also need to be adjusted. Default: 125, Range: 10~240;

Background Brightness is the offset value that is used to add or subtract the background. Default: 93; Range: 10~240;

This will set all 3 values to the Default ones;

Clicking Next> button will pop up an Auto Align dialog as follows:

None  Considering no Shift+Scale+Rotate among the selected images in the fusion process;

Shift+Scale  Considering Shift+Scale among the selected images in the fusion process; Rotation is not considered in this option;

Shift+Scale+Rotate  Considering Shift+Scale+Rotate among the selected images in the fusion process; If this mode is checked, The Maximum Angle slide bar will be enabled.

Maximum Angle  The Maximum Angle is used to set the upper limit in Rotate alignment. The Default is 1 degree. Range: 0.1~10;

User can select the proper Auto Align mode according to whether there is shift, scale or rotate among the images to be processed. The time consumption of EDF is related to the setting of the Maximum Angle. The time will increase when the Maximum Angle increases and the relationship between them is non-linear. The default is 1.0°;

Clicking <Back will return to Option dialog and clicking Finish will begin the EDF
operating according to the previous setup. ToupView will display the EDF(Extended Depth of Focus) progress bar as follow:

The final EDF result is shown below:

12.3.1.2 Weighted Average

The setups of the Weight Average are the same as those of the Maximum Contrast. About the setup details, please refer to Maximum Contrast in Sec.12.3.1.1.

12.3.1.3 FFDSSD

Choosing FFDSSD in the Select Method dialog will pop up a FFDSSD Options dialog as below:

Determine the reference image automatically: Before EDF, FFDSSD will evaluate all the images to determine the reference image for feature matching. After the reference image is determined, FFDSSD will perform feature matching between the reference image and the other images to find the alignment parameters.

The default is checked. If the Determine the reference image automatically is unchecked, ToupView will take the first image as reference image in the alignment
Clicking Finish button will begin the EDF, an EDF (Extended Depth of Focus) progress bar dialog will display as follows:

The final EDF result is shown below:
12.3.2 Image Window EDF

Similar to the Browse window EDF, Image window EDF is also a very useful tool to generate a clear image by combining a sequence of previously captured or opened multi-focus images. Choosing the Process>EDF... command, the following dialog will be brought up (assume 01.jpg 02.jpg ... 15.jpg are already opened in ToupView):

Clicking on the image file name in the Open combobox will highlight the image, and then the Add>> button is enabled (Click on the selected images will deselect them). Click the Add>> button, the highlighted images will be added into the Selected list box, which will be fused later.

Clicking the Add all button will add all images in the Open combobox into the Selected list box.

If images in the Selected combobox are highlighted, the Delete button will be enabled. Click the Delete button, the highlighted images in the Selected combobox will be removed.

Clicking the Clear button will remove all the images in the Selected list box, including the unselected ones. The button will be disabled if there is no image in the Selected combobox.
When the desired images are all selected (If more than 2 images are added in the Selected List box, the Next> button will be enabled), clicking on the Next> button will start EDF process.

ToupView will display the EDF(Extended Depth of Focus) progress bar as follows:

![EDF progress bar]

The final EDF result is shown below:

![EDF result]

**NOTE:** Images used for fusing must be the same size; otherwise there will be a prompt when adding different sizes of images as below. The prompt dialog indicates which image is not the same size with the others.

![Prompt dialog]

**12.3.3 Video Window EDF**

Make sure that the ToupView package and UCMOS or UHCCD camera are correctly installed. Turn on the microscope's light.

1. Run ToupView and start the camera;
2. Choosing the **Process>EDF** command or clicking on the toolbar will bring up a dialog called “Capture Image”;

3. Use the microscope **coarse** or **fine** focus knobs to move the sample stage up and down, in order to find the positions where the clearest regions of the whole sample can be seen on the **Video** window;

4. Click the **Capture** button to capture an image into the image list which will be used for the **EDF** operation.

5. Unless there is 1 captured image, the **Clear** buttons will not be enabled. Unless there are more than 2 captured images, the **Next>** buttons will not be enabled. If the captured images are not satisfactory, click the **Clear** button to clear the captured image(s), and capture new image(s).

6. If more than 2 images are captured, Clicking **Cancel** will end the **Capture Image** and return to the **Video** window. If the **Next>** button is clicked, ToupView will pop up a dialog called **Selected Method** to begin the **EDF** configuration process. About the configuration detail, please check **Browse Window EDF** in Sec.12.3.1.

The final fused image will be displayed in a new active image window and its title bar will be associated with a digit assigned by ToupView.
Note: a). Use the coarse and fine focus knobs to move the sample stage up and down; b). Clicking the Capture button will capture the current image into the image fusion list; c). Repeating steps 1-4 until there are enough images; d). Clicking the Fusion button will start image fusion. Waiting for some time and a fantastic fusion result will be displayed in a new image window;

12.4 Segmentation & Count

Choose the Process>Segmentation & Count command to realize the segmentation and count of the interested image. The arrangement of Segmentation & Count is very special and some explanations are needed here to clarify it in details:

1. The function provides users with five methods which are Watershed(W), OTSU Dark, OTSU Bright, RGB Histogram, HSV Histogram and Color Cube. Users can select any one of those 5 methods, but after selecting any one of them, the others will be disabled.

2. After segmentation, there may exist adhesions. Then what we should do is segment connected object manually by choosing the Split Objects function.

3. When the users get the expected results, they can choose the Counting Results menu and get the statistics and analysis results.

According to the counting result, you can go back from step 2 or 3 to step 1 or 2 to repeat segmentation or split objects operation.
**Help Manual**

**Note:** If the users choose None in the Label button at the Count Options dialog, then regardless of the type of Method set, there is no Label for Index, Area or Perimeter on the image. But the None, Circle and Ellipse will show the segmentation results. That’s why ToupView name the menu as Segmentation & Count. That is, this function can achieve either the image Segmentation or Count. In this regard, please refer to the Process>Segmentation & Count > Watershed(W) in the Count Options dialog.

12.4.1 Watershed(W) •••

Watershed segmentation method is a mathematical morphology segmentation method, which based on topological theory. The basic idea is taking the image as a topological geomorphology on geodesy, and each image pixel gray value indicates the altitude, boundaries of each local minimum value and its impact area called catchment basins and the formation of watershed catchment basins. So the formation of the watershed concept can be illustrated by simulating the immersion process. In each local minimum value of the surface, piercing a hole, then the entire model slowly immersed in water, with the immersion of the deepening impact of the domain of each local minima slowly expands outward in two catchments basin at the confluence build dams that form the watershed.

Watershed is suitable for relatively simple background target object or target object with a relatively large difference between the background images instead of the more complex application.

Choose Process>Segmentation & Count > Watershed(W)..., there will pop up the following dialog: (**Note:** Segmentation & Count function only works for 24 bits, otherwise all the sub-menu items will be disabled. Users can change the Color Bits to 24 bits by choosing Image>Mode>Color Quantize...)
Approximation including three options: 1) **None**: drawn the actual outline of the segmented object; 2) **Circle**: The actual outline fitting into a perfect circle, users can get fit **Radius** of each object in the Count Result dialog; 3) **Ellipse**: The actual outline fitting into an ellipse, users can get fit **Axis** of each object in the Count Result dialog.

When checking **With Holes** function, the segmented object’s **Outline** will be marked with **Color**. Meanwhile the holes are also marked with **Color** and its parameters will be output in the image (**Hole** is defined as the target grayscale or the color close to the background pixels). The left figure below is the segmentation result without checking **With Holes**; the right below is on the contrary. **With Holes** option is usually used to get hole parameters.

Outline Style: Including 3 options: 1) **Outline**: objects are marked by outline, the color can be user-defined; 2) **Filled**: the segmented objects will be filled with custom colors; 3) **None**: no marked outline for the segmented object;

**Color**: Custom colors used to mark the **Style**;
**Help Manual**

| Label | Method: Including 3 options: 1) XOR: with the current pixel's XOR color to mark the current object segmentation; 2) True: marked with the specified Color; 3) False: no mark for the objects;  
Note: If users choose False in the Label group box, then regardless of the type of Method, there is no display for Index, Area or Perimeter. But the None, Circle and Ellipse will displayed on the segmented image. That’s why ToupView call it Segmentation & Count; |  
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Color: Custom Color used to represent the color of Label. When selecting XOR in the Method, the Color selection will be disabled, but the ToupView will automatically mark the segmented image with the current pixel’s XOR color;</td>
</tr>
<tr>
<td></td>
<td>Type: Including 3 options: 1) Index: use numbers to mark the segmented object. 2) Area: the object area is marked by outline area size. 3) Perimeter: the object perimeter is marked by the outline perimeter;</td>
</tr>
</tbody>
</table>
| Area  | Minimum: determine the lower limit of the area. that is, if the object area is less than the lower limit, it will not be included;  
Maximum: determine the upper limit of the area. that is, if the object area is greater than the upper limit, it will not be included; |  
| Perimeter | Minimum: determine the lower limit of the perimeter. that is, if the object perimeter is less than the lower limit, it will not be included;  
Maximum: determine the upper limit of the perimeter. that is, if the object perimeter is greater than the upper limit, it will not be included; |  

The figure below shows image Segmentation & Count results with watershed method with setting in Count Option dialog.
12.4.2 OTSU Dark

OTSU is proposed in 1979 by Japanese scholars, which is a method to determine the threshold of an adaptive, also known as Otsu method, referred to as OTSU. It is based on the gradation characteristic of the image, and divided the image into the background and the target. The bigger the OTSU is between background and the target, the larger difference between the two parts images. The wrong part of the background or the wrong part of the target will lead to smaller differences between the two parts. Therefore, the maximum OTSU means the minimum probability of misclassification.

OTSU Dark segmentation method means segment the dark object from the bright background using OTSU algorithm. Its Count Options dialog is exactly the same with the Watershed Count Options. Below are bright background with dark object (bottom left) and its segmentation result (bottom right) for reference:

12.4.3 OTSU Bright (B)

OTSU Bright segmentation method means segment the bright object from the dark
background using OTSU algorithm. Its Count Options dialog is exactly the same with the Watershed Count Options. Below are dark background with bright object (bottom left) and its segmentation result (bottom right) for reference:

![Segmentation Result](image)

12.4.4 RGB Histoman •••

RGB Histogram segmentation is based on image histogram where image pixels between a specified histogram upper and lower range will be color processed. The segmented area can be adjusted by mouse to drag two vertical lines in histogram, or by inputting precise value in RGB upper and lower edit box directly and clicking “Enter” to make it effective. The Color representing the segmentation area can be customized by system palette. For a 24-bit true color image, segmentation can be realized by R, G, B channels respectively.

Choose Process>Segmentation & Count>RGB Histogram••• shows Histogram dialog, each function is specified as below:

![Histogram Dialog](image)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Value</td>
<td>in the currently selected region of histogram segmentation, corresponding to Left Vertical Line position in</td>
</tr>
<tr>
<td>OK</td>
<td></td>
</tr>
<tr>
<td>Options...</td>
<td></td>
</tr>
<tr>
<td>RGB: Green</td>
<td></td>
</tr>
</tbody>
</table>

107
Help Manual

<table>
<thead>
<tr>
<th>histogram. Users can segment the pixels bigger than the <strong>Left value</strong> by inputting a value in this edit box or dragging the <strong>Left Vertical Line</strong> in histogram. When input a <strong>Left Value</strong> in this edit box, users should click enter to make the value effective. Meanwhile, the <strong>Left Vertical Line</strong> will move to the place the <strong>Left Value</strong> represents. <strong>Left Value</strong> range: 0~current <strong>Right Value</strong>. The current <strong>Left Value</strong> is 0;</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Right Value</strong> in the currently selected region of histogram segmentation, corresponding to <strong>Right Vertical Line</strong> position in histogram. Users can segment the pixels, bigger than the <strong>Left Value</strong> and smaller than <strong>Right Value</strong>, by inputting a value in this edit box or dragging the <strong>Right Vertical Line</strong> in histogram. When input a value in this edit box, users should click enter to make the value effective. Meanwhile, the <strong>Right Vertical Line</strong> will move to the place the <strong>Right Value</strong> represents. <strong>Right Value</strong> range: current <strong>Left Value</strong> ~255. The current <strong>Right Value</strong> is 79;</td>
</tr>
<tr>
<td>A histogram channel of the currently <strong>RGB</strong> histogram. It can be <strong>R</strong> histogram, <strong>G</strong> histogram or <strong>B</strong> histogram;</td>
</tr>
<tr>
<td>Show all channel <strong>RGB</strong> histogram. When uncheck <strong>Show All</strong>, only a selected histogram channel will be shown;</td>
</tr>
<tr>
<td>Used to identify the <strong>Color</strong> of the segmented pixels; The default is green;</td>
</tr>
<tr>
<td>When users click <strong>Options</strong> button, a <strong>Count Options</strong> dialog pops up as below. The setting of <strong>Count Options</strong> dialog is the same as that of Waltershed’s <strong>Count Options</strong> dialog, details can be referred to <strong>Process&gt;Segmentation &amp; Count&gt;Watershed(W)</strong>;</td>
</tr>
</tbody>
</table>
Example of RGB Histogram is as follows:

1. Open an image and then choose Process>Segmentation & Counting>RGB Histogram menu, a Histogram dialog shows as below. When the mouse moves in the image area, the cursor will be displayed as Color Picker Cursor;

2. Move Color Picker Cursor to any pixel of the image, shown as above, RGB value of the current pixel will be displayed in the bottom Histogram window. Here R is 249, G is 51, B is 31, showing the RGB value of the ideal segmentation area, record the three values.

   Move the mouse to the background area, the RGB value of Color Picker Cursor is 79, 79, 79. In order to accurately segment out the target, users can set RGB values of the segmented pixels in the initial interval, and those of background out of the initial interval. For example, the RGB values can be set to the initial interval as follows:

   R is set to the initial interval: 200~255;
G is set to the initial interval: 0~60;
B is set to the initial interval: 0 ~ 60;

When setting completed, the segmentation effect is shown as below:

4. Move again the Color Picker Cursor to any other unshadded pixels, then the RGB value shown in left bottom of histogram is 237, 70, 45 as below:

It’s easily found that here G channel, defined 60, is too small to get the pixel segmented. Then initial interval for G channel can be adjusted from 0~60 to 0~80 to segment the pixels nearby. (Note: If the background pixels of a single channel is within the initial interval, no segmentation change will take place. Only all three channels of the background pixels are within the initial intervals can the pixels be segmented) The segmentation effect by readjusting G initial interval is shown as below:
5. Repeat step 4 and readjust initial interval of each RGB channel to achieve perfect segmentation.

12.4.5 HSV Histogram

HSV Histogram segmentation is based on image histogram where image pixels between a specified histogram upper and lower range will be color processed. The segmented area can be adjusted by mouse to drag two vertical lines in histogram, or by inputting precise value in HSV upper and lower edit box directly and clicking “Enter” to make it effective. The Color representing the segmentation area can be customized by system palette. For a 24 bits true color image, segmentation can be realized by H, S, V channels respectively.

Choose Process>Segmentation & Count>HSV Histogram shows Histogram dialog, each function is specified as below:

<p>| Left Value | in the currently selected region of histogram segmentation, corresponding to Left Vertical Line position in histogram. Users can segment the pixels bigger than the Left |</p>
<table>
<thead>
<tr>
<th><strong>Help Manual</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>value by inputting a value in this edit box or dragging the Left Vertical Line in histogram. When input a Left Value in this edit box, users should click enter to make the value effective. Meanwhile, the Left Vertical Line will move to the place the Left Value represents. Left Value range: 0~current Right Value. The current Left Value is 0;</td>
</tr>
<tr>
<td>Right Value in the currently selected region of histogram segmentation, corresponding to Right Vertical Line position in histogram. Users can segment the pixels, bigger than the Left Value and smaller than Right Value, by inputting a value in this edit box or dragging the Right Vertical Line in histogram. When input a value in this edit box, users should click enter to make the value effective. Meanwhile, the Right Vertical Line will move to the place the Right Value represents. Right Value range: current Left Value ~255. The current Right Value is 79;</td>
</tr>
<tr>
<td>A histogram channel of the currently HSV histogram. It can be H histogram, S histogram or V histogram;</td>
</tr>
<tr>
<td>Show all channel HSV histogram. When uncheck Show All, only a selected histogram channel will be shown;</td>
</tr>
<tr>
<td>Used to identify the Color of the segmented pixels; The default is green;</td>
</tr>
<tr>
<td>When users click Options button, a Count Options dialog pops up as below. The setting of Count Options dialog is the same as that of Waltershed’s Count Options dialog, details can be referred to Process&gt;Segmentation &amp; Count&gt;Watershed(W);</td>
</tr>
</tbody>
</table>
Example of HSV Histogram is as follows:

1. **Open** an image and then choose **Process>Segmentation & Counting>HSV Histogram**... menu, a **Histogram** dialog shows as below. When the mouse moves in the image area, the cursor will be displayed as **Color Picker Cursor**;

![Color Picker Cursor](image)

2. **Move** **Color Picker Cursor** to any pixel of the image, shown as above, HSV value of the current pixel will be displayed in the bottom Histogram window. Here **H** is 186, **S** is 114, **V** is 206, showing the HSV value of the ideal segmentation area, record the three values.

Move the mouse to the background area, the HSV value of **Color Picker Cursor** is 214, 87, 228. In order to accurately segment out the target, users can set HSV values of the segmented pixels in the initial interval, and those of background out of the initial interval. For example, the HSV values can be set to the initial interval as follows:

- **H** is set to the initial interval: 60~200;
Help Manual

- S is set to the initial interval: 90~130;
- V is set to the initial interval: 0~210;

When setting completed, the segmentation effect is shown as below:

4. Move again the Color Picker Cursor to any other unshadded pixels, then the HSV value shown in left bottom of histogram is 194, 79, 212 as below:

It's easily found that here S channel, defined 90~130, its lower limit is too big to get the pixel segmented. Then initial interval for S channel can be adjusted from 90~130 to 60~130 to segment the pixels nearby. (Note: If the background pixels of a single channel is within the initial interval, no segmentation change will take place. Only all three channels of the background pixels are within the initial intervals can the pixels be segmented) The segmentation effect by readjusting S initial interval is shown as below:
5. Repeat step 4 and readjust initial interval of each HSV channel to achieve perfect segmentation.

12.4.6 Color Cubic

Choose Process>Segmentation & Count>Color Cube..., a dialog called Color will pop up as below;

At this moment, the Colorizing Pipette (Default) is checked by default. Click the image will set the average color value in the masked area as Basic Value. ToupView will segment the image by choosing the pixel within Basic Value±Tolerance color range and mark it with current selected Color. By clicking the target pixel repeatedly, ToupView can continuously add new pixels within the Basic Value±Tolerance color range into the target and thus acquiring continuous segmentation colorizing.

When some undesirable pixels have been added into the segmentation data, the De-Colorizing Pipette can be used to wipe off the undesirable pixels. This operation process is the same as Colorizing Pipette, that is, to set the average color value of the clicked-pixel’s Mask Area as Basic Value and wipe off the segmentation data, which is
within the Basic Value±Tolerance color range.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📍</td>
<td>Colorizing Pipette: Collect average color value of the clicked-pixel's Mask Area as Basic Value and add pixels which are within Basic Value±Tolerance color range into the segmentation data;</td>
</tr>
<tr>
<td>🎨</td>
<td>De-Colorizing Pipette: Collect average color value of the clicked-pixel's Mask Area as Basic Value and wipe off the segmentation data, which is within the Basic Value±Tolerance color range;</td>
</tr>
<tr>
<td>3*3</td>
<td>Mask Area: When Colorizing Pipette or De-Colorizing Pipette is used to click the image, a Mask Area is also needed to calculate the average color value of the clicked pixel. The Mask Area’s color value will be used as Basic Value. Color values within the Basic Value±Tolerance range can be added to or wiped off from the segmentation data. The default Mask Area is 3<em>3, other options are 1</em>1, 5<em>5, 7</em>7;</td>
</tr>
<tr>
<td>RGB</td>
<td>The average RGB values of the Mask Area;</td>
</tr>
<tr>
<td>Tolerance</td>
<td>There are 3 Tolerance values, they are R, G and B. User can make fast and accurate object segmentation by selecting a proper Tolerance value according to their experience. The default R, G and B Tolerance values are 10;</td>
</tr>
<tr>
<td></td>
<td>Used to mark the color of the segmentation area; The default Color is green;</td>
</tr>
<tr>
<td>Options...</td>
<td>When clicking the Options button, a Count Options dialog as below will pop up. This dialog is the same as that in Process&gt;Segmentation &amp; Count&gt;Watershed (W).... Please refer to Process&gt;Segmentation &amp; Count&gt;Watershed (W)... for the detailed operation of this dialog;</td>
</tr>
</tbody>
</table>
Here is an example to demonstrate the Color Cubic segmentation process:

1. **Open** an image as below:

![Image of a sample image](image)

2. Because of the inevitable noise in the image, an image smooth operation should be done first. There are many algorithms to perform the image smooth operation and here we are to process it as follows: choose **Process>Filter** menu and click **Morphological** property page and a dialog will pop up with parameters as shown in the figure below on the left side. Click **OK** and the final smoothed image is shown below on the right side.
3. Choose Process>Segmentation & Count> Color Cube..., a Color dialog will pop up as shown below:

4. At this moment, the Colorizing Pipette is checked. Click the pixel wish to segment. that is to say, select the color area which is interested in. If some undesirable color area is included in the segmentation area, just check the De-Colorizing Pipette and click the undesirable pixels, thus the undesirable pixels will be wiped off. When the segmentation process is completed, click OK and the Segmentation & Count operation will be carried out.
The result of segmentation after the first clicking at the pointed area with **Colorizing Pipette**

The result of segmentation after the second clicking at the pointed area with **Colorizing Pipette**

The result of segmentation after the second with the **De-Colorizing Pipette** (slight difference exists as inaccuracy in position)

The result of segmentation after countless clickings with **Colorizing Pipette**

5. Click **Options** to set **Outline**, **Label** and etc., the final results is shown below. So far the primary segmentation is completed.
12.4.7 Split Objects

It can be found out in this segmentation, particle #16 (located in the upper middle of the image) is not a single object but actually two separate one. However they have been calculated as a single object. Choosing Split Objects will correct this problem. Object splitting with Split Objects is discussed below.

As is shown in the image below, move the cursor onto target #16. Click the left mouse button and draw a straight line.

When pressing down the left mouse button, the cursor should not touch the target — the starting point of the split line should be off the target that is to be separated. Move the cursor to the bottom right of the target — the ending point of the split line should also be off the target that is to be separated. Release the left mouse button when this operation is completed. A split line is shown between the two adhesive objects as shown below:
After the left mouse button is released, ToupView will re-count the whole image. The result of re-counting is shown as below. The previous #16 turns out to be #12 and #17 now:

Unchecking or choosing Split Objects menu again will hide the split line. The final result of hiding the split line is shown as below. The whole Split Objects process is completed when the split line is hidden.
12.4.8 Count Result (T) ••

Count Result is a way to show count statistical result of the current image. Count Result dialog includes Index, Center, Radius (major-minor axis or non), Area and Perimeter, as is shown below. The unit of statistical result is the same as what the user selects in the Unit for the displayed image. Click Index, Center, Radius (major-minor axis or none), Area and Perimeter and the statistical result will be automatically sorted according to their data. Choosing a certain item can check the split object in the image. In the meanwhile, Index (or Area and Perimeter) of the other targets will be hidden automatically.

The Center column in Result is relevant to the Approximation option in the Options dialog. When selecting Circle, radius of the circle will be listed as Radius column and when choosing Ellipse, major-minor Axis of the Ellipse will be listed as Axis column; when
Help Manual

selecting None, no column shows up.

Click Export and then the statistical result, together with the image of Segmentation & Count, will be exported to an Excel sheet for further analysis and processing.

12.5 Image Stacking

The image-stacking method is a form of speckle imaging commonly used for obtaining high quality images from a number of short exposures with varying image shifts. It has been used in astronomy for several decades, and is the basis for the image stabilization feature on some cameras. The method involves calculation of the differential shifts of the images. This is easily accomplished in astronomical images since they can be aligned with the stars. Once the images have aligned, they are averaged together. It is a basic principle of statistics that variation in a sample can be reduced by averaging together the individual values. In fact, when using an average, the signal-to-noise ratio should be increased by a factor of the square root of the number of images.

Image stacking can also be used for biological microscope image and fluorescent microscope image to increase the image SNR and dynamical ranges; this is why we introduce image stacking into ToupView.

ToupView Image Stacking introduced advanced image matching techniques for rotated, shifted and scaled images. The user can record a short video to get a high quality stacked image at ease without considering the image rotation, shifting and scaling between a series of images in the video. The steps of Image Stacking are described as below:

1. Choose Processing>Image Stacking... menu, a Windows Open dialog will pop up as shown below;
2. Choose the right video file recorded before in the **Open** dialog, here we can open “test.avi” for demonstration, click **Open** to open the avi file;

3. Then an **Image Stacking** dialog will pop up to show the progress of the each image’s stacking progress.

4. If **Cancel** is pressed, the **Image Stacking** will be canceled. After the stacking is finished, a stacked image will be displayed in a new window for further application. The final image is shown as below. One can find the stacked image signal to noise ratio is greatly improved. From the stacked image has some black edges, this is because the images in the video is moved and in the stacking process, ToupView will added 0 to the image area that has no corresponding pixel in the reference image (we choose the first image in the video file as the reference image).
Note:

1. ToupView support wmv, asf, avi, mp4, m4v, 3gp, 3g2, 3gp2, 3gpp, mov, mkv, flv, rm, rmvb for Image Stacking operation;

2. In the Image Stacking process, ToupView takes the first frame as the reference image, this means the first frame is very important and should be assure the first frame to be the right image scene and the subsequent frames have a greater overlap region with the first frame.

12.6 Color Composite

Use the Color Composite dialog box to create and configure color composites using black and white source images. You can access the Color Composite dialog box through the Color Composite menu item from the Process menu.
You can combine gray-scale images into a color composite. Any group of gray-scale images that are of the same size can be mixed in a color composite. Images of 8-, 12-, 16-bit integer or floating point format are combined into a 24-bit color composite. Each input channel will have individual LUT adjustments, as well as a registration offset to line it up with the rest of the images.

You can also combine individual channels from a single image. Each channel will be listed separately, as shown here:

**Source Images:** The **Source Images** combo box displays the images available for color mixing. The **Source Image** list is initially filled with a list of the gray scale images that are currently open. The size of the color composite is determined by the first input image selected. Once this is entered, the list is filtered to contain only images of the same size as the initial selection.
Add: Click the **Add** button to add an image to the mix. You will be prompted for the color to be assigned to that image from the **Set Color** dialog.

Delete: Use this button to delete the selected image from the list.

Colors: The **Colors** combobox displays the images selected for color mixing.

To change the color within the list box, double-click to select the image name (the **Select Color** dialog box appears) or highlight the name and click the **Set Color** button.

To delete colors/images from the **Colors** list box, first click on the color/image to highlight it then press the **Delete** button within the **Color Composite** dialog box.

Color Bar: The picture item box on the left side of the **Colors** list indicates the color associated with each image in the composite. The **Color Bar** will scroll with the contents of the **Colors** list box.

Set Color: This option determines the **Color** value used for the selected channel in the final image display. Clicking on the **Set Color** button brings up the **Select Color** dialog box.
Directly select a color by:

1) Dragging the **Color Value Slider** to the desired color on the **Color Bar** (range of 0 to 359°): or

2) Clicking the appropriate **Color** button on the **Color Palette**. The **Color Bar** represents **Color** degrees in the standard color wheel representation, and the **Color Palette** contains a subset of possible **Colors** (pure red, green, blue, cyan, magenta, and white): or

3) Select a dye in the dye list, and click the **Select Dye** button.

**Note**: You can navigate through the **Select Color** dialog box by using the `<Tab>` and `<Shift + Tab>` keys to cycle through the items in the dialog box.

**Intensity** is determined by the image the **Color** is applied to, and **saturation** will always be 100%.

The only exception to this is the “white” **Color**, which has by definition a saturation of 0%. Selecting a value greater than or equal to 360 (dragging the **Color Value** slider over to the far right) is a choice of white, which results in a non-tinted (gray) image.

The elements of the **Select Color** dialog box are:

**Color Bar**: The **Color Bar** shows a rainbow displaying the **Colors** underneath the appropriate point of the **Color Value** slider.

**Note**: 

128
If Color Value Slider is the selected (highlighted) selected control, then you can also control the slider with keyboard strokes:

Use the left/right arrow <-> or <->keys to move the slider incrementally.

Press the <Page Up> and <Page Down> to move the slider in “chunk” sections along the Color Bar.

Use the <Home> and <End> keys to move the slider to the beginning and end of the Color Bar.

Selected: This color block displays the new Color selected by the Color Value slider bar or the Color Palette.

Selected Color: The Selected Color text field displays the corresponding numeric Color value of the Selected color block described above. The Selected Color value is expressed as an HSV color, with the red value first, followed by the green and blue values. If the color corresponds to a dye color, the dye name will be displayed. If the dye color corresponds to a color palette color, the name of the color will also be displayed.

Current: The Current color block displays the starting Color of the channel.

Color Palette: The Color Palette proves an alternate method of selecting a Color. Clicking on an item in the Color Palette will set the Color Value slider to the correct value and update the displays in both the Selected color block and Selected Color text field.

For example, clicking on the white button on the Color Palette will set the Color Value slider to the right, change the Selected color block to white, and cause the Selected Color text box to display “White”.

Adjust: The controls in this section are used to adjust the color composite contribution from each image, or for the color composite preview itself. You can adjust the input image that is currently selected in the Colors list by clicking the selected button. When you want to adjust the color composite preview, or you want no image is selected in the Colors list, use the All button.
**Help Manual**

*Registration*: Registration allows you to correct for mis-registrations of images caused by filter-induced optical shifts. Use the directional keys to shift the selected image in the $x$- and/or $y$- direction, with respect to the rest of the input images. One click moves that channel one pixel in the direction indicated. Blank areas are filled with black. The key labeled “$0,0$” will re-center the selected image.

The registration shift for the selected channel or the overall image is displayed in the static text box below the directional keys.

*Contrast*: Use the BCG sliders along with the Best Fit and Reset buttons to adjust the contrast of the selected image or the composite.

*BCG sliders*: The Brightness, Contrast, and Gamma sliders are similar to the Contrast Enhancement feature in ToupView. You can also adjust each channel individually or collectively by using the Selected or All radio buttons (to the left of the BCG sliders in the Adjust group box).

*Best Fit*: Click this button to perform a Best-Fit contrast stretch on the selected input, automatically setting the Brightness and Contrast settings accordingly (Gamma will be reset to 50.). This method is identical to the Best Fit contrast adjustment under the standard Contrast Enhancement feature of ToupView. Best Fit is useful for first pass adjustments.

*Reset*: Pressing the Reset button automatically resets the BCG settings. If the Adjust radio button is set on All, the BCG settings for the overall color image will be reset.

*Frame*: Use the frame slider to adjust the frame of the selected image that is used for the preview, or the active frame of the composite. (Please see the discussion of Color Composite and Image Sequences that follows this section.)

*Background*: Select one of the available images to be the background color in this combo box. The rest of the image planes are subtracted from the background image — effectively punching “holes” into it and allowing the foreground colors to show without mixing with the background. This is most effective where the background covers large areas and the other images have smaller objects within the background objects.
Background allows the other inputs to be displayed “in front of” the background inputs, minimizing color mixing. For example, ToupView can display a red dot on a blue background without turning the dot to magenta.

Selecting None causes all images to be equally mixed.

New: Click on the New button to discard the current color composite image, and start over.

The Source Images combo box will reset to include all gray scale images (including floating point images). Selecting an image from the list will create a new composite the same size as the initial selection. As mentioned previously, the source images list will be filtered to contain only images of the same size as the initial selection.

12.7 Range••• Shift+R

The Process>Range••• command allows set the intensity levels of the image to increase the contrast and enhance the display in low-light situations. Choose the Range command to open the Range dialog.

Two vertical markers show the upper and lower limits of the intensity levels. These markers can be moved with mouse through the drag and drop method. For a color image, the histogram will reflect the red, green, and blue values with corresponding colors lines.

Two Edit controls indicate the values of the intensity levels. Choose the spin buttons to increase or decrease these values. All values between 0 and the lower limit will be black and all values between the upper limit and the upper end of the scale will be white. These two edit control values corresponding to the two vertical markers show the upper and lower limits of the intensity levels. Defaults are 0 and 255 respectively.

Reset The Reset button allows Reset the black and white levels to the high and
Help Manual

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Best Fit</td>
<td>The Best Fit button automatically sets the intensity levels to the Best Fit.</td>
</tr>
<tr>
<td></td>
<td>Best Fit instructs ToupView to optimize the brightness and contrast values</td>
</tr>
<tr>
<td></td>
<td>for the particular image.</td>
</tr>
<tr>
<td>Invert</td>
<td>The Invert button reverses the color of the image.</td>
</tr>
<tr>
<td>Update</td>
<td>Update will refresh the display Range with the most current image information.</td>
</tr>
</tbody>
</table>

12.8 Binary

Binary is a kind of gray level process. If the gray of the pixel is greater than the given threshold, the pixel's color will be changed into white. Otherwise, the pixel's color will be changed into black. Although the process may lose some information, it is an important step of other processes.

![Binary dialog](image)

The curve on the Binary dialog shows the gray distribution of the image.

The Line in the dialog indicates the threshold value. Drag the line to change the threshold, or change the value in the Line position edit box (in the top left corner of the dialog) to move the Line.

The Line position edit box shows the current position value of the Line; Modify the value will move the Line at the same time;

Click the "Best Fit" button to apply the auto threshold process to the image. It uses an automatic threshold to make the image Binary.

12.9 Pseudo Color

Note: Image must be in Gray Scale.

Choose the Pseudo Color command to "colorize" the active monochromatic image. This is used to highlight certain features in a gray scale image such as display all densities above a certain point in red, or, the imaging device recorded thermal
information, all temperatures below a certain point can be revealed in blue color.

When **Pseudo Color** a monochromatic image, a special palette need to be build with which the monochromatic image is displayed. **Pseudo Coloring** an image does not modify the pixels' values in image bitmap (it does not convert image to true color or palette). It simply associates a **Pseudo Color** palette with the image that interprets the gray-level values in the image as color.

Pseudo Colored images are very similar in structure to palette class images, but they differ in a couple of important ways. First, the pixels' values in a **Pseudo Colored** image actually represent continuous-tone intensity information, whereas a palette image's pixels carry no intensity significance. Secondly, a palette image includes a palette table that is actually part of the image file.

The colors used to map the gray values can be selected. The buttons at each end of the color strips ( or ) will bring up the color dialog separately, which allows select the start and end colors of the range.

**12.10 Surface Plot**

The **Process>Surface Plot** (or 3-D Plot) tool creates a 3-D representation of the intensity of an image. When choosing the **Surface Plot** command, keep in mind that $X=\text{image width}$ and $Y=\text{image height}$, and $Z=\text{pixel gray value}$.

In the viewpoint window, the **elevation** and **rotation** of the image can be adjusted by dragging the mouse on the image.
Position Solid: The left edit control indicates the relative position of the entire image in the viewpoint window, whose default value is 0.5. The right edit control indicates the relative height of the display of the Z scale, whose default value is 1.

Reset: Set the Position Solid's two edit controls to their default values.

Image Background Color: Choose this command to display a color dialog where one can adjust the background color of the viewpoint window.

Capture: Capture the active image in the viewpoint window as a new image.

Color Table: Select the colors to map the gray values found in the surface plot. The button at each end of the color table brings up the color dialog, which allows select the start and end colors of the range. (Please refer to Pseudo Color for more information)

12.11 Line Profile

Choose the Process>Line Profile command to illustrate how pixels along a selected line are distributed by graphing the number of pixels at each color intensity level.

Choose the Measurements>Arbitrary Line, or Measurements>Horizontal Line or Measurements>Vertical Line command to draw a line on the image and choosing the Process>Line Profile will bring up a Line Profile dialog as below(The procedure can be
Line Profile: In a Line Profile, the X-axis represents the spatial scale, and the Y-axis represents the intensity values which range from 0 to 255. If the image is a grayscale image, the gray value will be profiled. If the image is an HSV color image, the R, G and B values will be profiled separately with the corresponding R, G and B colors.

**Background:** Open the windows color dialog to set the background color of the profile window;

**Title:** Use this command to set a title on the Line Profile image;

**Capture:** Capture the image in the Line Profile window as a new untitled image;

**Copy:** Copy the Line Profile window's content onto the clipboard;

**Save as...** Save the Line Profile image in bmp format.

### 12.12 Mosaic

Mosaic is a process that can combine the images opened into a new image. This will open the following dialog:
**Help Manual**

**ImgList page**

**Available Images**: Images opened with ToupView.

**Add>>**: Add the opened images to the Selected Images list view

**Add All>>**: Add all the opened images to the Selected Images list view

**Remove**: Select the images and remove them from the Selected Images list view.

**Clear**: Remove all the images from the Selected Images list view.

**Property page**

**Title**: The title wanted

**Footer**: The footer wanted

**Arrangement**: The Mosaic Images distribution on the page

**PageSize**: The page size for the Mosaic Images

If everything is set, click OK to end the Mosaic Images operations and a new image window will be displayed and the final results should be
13 Layer

13.1 About layer
ToupView Layer is like sheets of stacked acetate. You can see through transparent areas of a Layer to the Layers below. You add a Layer to position the image content on the Layer, like sliding a sheet of acetate in a stack. You can also hide/show a layer to make content invisible/visible.

You use layers to perform tasks such as perform the measurement on the image without polluting the image and save it for the future adjustment for the further analysis, adding text to an image, or adding vector graphic shapes.

13.2 Organizing layers
A new image has a single Layer called Background layer. The number of additional layers you can add to an image is limited only by your computer’s memory.

You work with layers in the Layers Sidebar. The Layer Sidebar help you organize and manage layers just like the Layer menu.

13.3 Layers for non-destructive measurement and label
Rather than edit image pixels directly, you can label the image with text and measure the image and leave the underlying pixels unchanged. Because of the non-destructively to images, you can later tweak or remove the label and the Measurement Objects.

13.4 Layer Sidebar
A: Make a New layer;   B: Remove a layer;   C: Set the Current layer;  
D: Show/Hide a layer;   E: Rename a layer;   F: Auto hide the Layer Sidebar;  
G: Right mouse button context menu for the Background layer;  
H: Right mouse button context menu for the Current not checked layer;  
I: Right mouse button context menu for the Current checked layer;  
J: Right mouse button context menu in the blank area;  

Note: a). Only one layer can be checked as Current Layer. If a layer’s “Current” is checked, the Visible will be checked automatically; b). The Current and Background layers cannot be removed. Only the non-current and non-background layers can be removed; c). All the Objects on the Current Layer can be selected, edited or exported; d). The non-current Layer can be Visible (checked) or invisible (unchecked).

13.5 Layer menu and layer sidebar page context menu
The function of the Layer menu and Layer Sidebar right mouse button context menu are the same. They are:

13.6 New

Setup a new layer. After the new layer is setup, it will be added to the end of the Layer
Sidebar’s items and the Visible and Current will be checked.

13.7 Remove
Remove the non-current Layer.

Note: the Background and Current Layer cannot be removed.

13.8 Current
Set the selected layer as the Current Layer. User then can edit the Object on the Current Layer or added new Object on the Current Layer.

13.9 Show/Hide
Set the non-current Layer visible or invisible. The Current Layer cannot be toggled between Visible and invisible state. It is always Visible.

13.10 Rename
Rename a Layer.

13.11 Export to Image
Export all the layers’ Measurement Objects to the image, this will pollute the image and cannot be recovered anymore.

13.12 Export to Microsoft Excel
Export the image plus all the Objects on the Current Layer to the Excel file.
14 Measurements

The Measurements menu is mainly used for the image measurement application. With this menu items, you can measure the image with many geometrical shape at ease. ToupView use Layer technique to perform the measurement operations. This will never pollute the image pixels. The Measurements menus and its submenus are shown below.

About the Layer technique, please check the Layer menu and Layer Sidebar in Sec.13.

About the Measurements setup, please check Options>Measurement ... and Measurement Sidebar in View>Sidebar menu in Sec.8.

About the Measurements menu’s toolbar icons, please check ToupView’s toolbar in Sec.4

14.1 Object Select

The Measurements>Object Select menu or the toolbar button will be enabled only when a new Measurement is made over the Background Layer.

After the Measurement is done on the specific layer, choose this menu to select the Objects.
1. The **Object** can be selected by clicking on it;

2. Select a group of **Objects** by including them in a rectangular area with **Object Select** command or by press down the **Shift** key and clicking the **Object** with left mouse button until all the desired **Objects** are selected.

**Note:** a) To check or modify the parameters of the selected **Object**, just select a single **Measurement Object** and the **Measurement Sidebar** will be activated automatically. Here you can edit the corresponding object parameters to modify its properties; b) The **Appearance, Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the selected **Object** type (The type could be the same or different).

### 14.2 Angle

1. Move the mouse on the image to point 1, mark it by clicking the left mouse button;

2. Move the mouse to point 2, mark it by clicking the left mouse button;

3. Move the mouse to point 3, mark the final point by clicking the left mouse button.

A label A1@50.26deg will be shown near point 2;

**Note:** a) To check or modify the parameters of the selected **Object**, just select a single **Measurement Object** and the **Measurement Sidebar** will be activated automatically. Here you can edit the corresponding **Object** parameters to modify its properties; b) The **Appearance, Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the
selected Object type (The type could be the same or different).

14.3 Point

Move mouse to the point; click the left mouse to mark it. It will show the point Label \( P_n \) and its position \( x \) and \( y \) over the image.

**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.4 Line

14.4.1 Line>Arbitrary Line

Draw Arbitrary Line between the two points on the specified layer.

1. Choose the Measurements>Line> Arbitrary Line command;

2. Move mouse to the 1st point; click the left mouse to mark it;

3. Move mouse to the 2nd point, click the left mouse to mark it again, a line with \( L_1 \) and its length will be shown.
Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.4.2 Line> Horizontal Line
Draw a Horizontal Line between the two points on the specified layer. When the first point is marked, the second point’s y coordinate will be restricted to equal to the first point’s y coordinate automatically.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.4.3 Line> Vertical Line
Draw a Vertical Line between the two points on the specified layer. When the first point is marked, the second point’s x coordinate will be restricted to equal to the first point’s x coordinate automatically.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated...
automatically. Here you can edit the corresponding **Object** parameters to modify its properties; b) The **Appearance, Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the selected **Object** type (The type could be the same or different).

### 14.5 Parallel

1. Choose the **Measurements>Parallel** command;

2. Move mouse and click to mark the 1st point;

3. Move mouse and click to mark the 2nd point;

4. Move mouse and click to mark the 3rd point;

5. Move mouse again, one will find the 4th point is always restricted to parallel to the line connecting point 1 and point 2. Click to mark the 4th point. Two parallel lines will be labeled and numbered.

**Note:** a) To check or modify the parameters of the selected **Object**, just select a single **Measurement Object** and the **Measurement Sidebar** will be activated automatically. Here you can edit the corresponding **Object** parameters to modify its properties; b) The **Appearance, Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the selected **Object** type (The type could be the same or different).

### 14.6 Vertical
14.6.1 Vertical>Four Points.

1. Move mouse and click its left button to mark the 1st point.

2. Move mouse and click its left button to mark the 2nd point. A line (the 1st line) connecting these two points will be overlaid on the image.

3. Move mouse and click its left button to mark the 3rd point.

4. Move mouse again, one will find the 4th point is always restricted to perpendicular to the line of point 1 and point 2. Click to mark the 4th point. Two vertical lines will be labeled and numbered.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.6.2 Vertical>Three Points

1. Move mouse and click its left button to mark the 1st point.

2. Move mouse and click its left button to mark the 2nd point. A line (the 1st line) connecting these two points will be overlaid on the image;

3. Move mouse and click its left button to mark the 3rd point. The 2nd line will be overlaid on the image which is perpendicular to the 1st one.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated.
Help Manual

automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.7 Rectangle

1. Move mouse to the 1st point; click its left mouse button to mark it;
2. Move mouse to the 2ed point; click its left mouse button to mark it. A Rectangle will be overlaid on the image according these two diagonal points.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.8 RoundRect

1. Use Arc object to determine the round size. Its size is 21.39X2=42.8;
2. Choose the Options>Measurement command, click Round Rectangle to set the Round x and y to 43 and 43 respectively;
3. Move mouse to the 1st point; click its left mouse button to mark it;

147
4. Move mouse to the 2nd point, click its left mouse button to mark it, a round rectangle with Rr1 and its width and height the in the two dimensions will be displayed.

![Image of a round rectangle with measurements](image.png)

**Note:** a) To check or modify the parameters of the selected *Object*, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding *Object* parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single *Object* is selected. The Calculation will be effective for a single selected *Object* or multiple selected *Objects*. Its calculated items will depend on the selected *Object* type (The type could be the same or different).

14.9 Ellipse

1. Choose the Measurements>Ellipse command;

2. Move mouse to mark the 1st point;

3. Move mouse to mark the 2nd point;

4. If it is not superposing with the shape on the image, choose the Measurements>Object Select command to adjust the position to adjust the Ellipse in order to coincide with the image shape.
Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.10 Circle

14.10.1 Circle>Center+Radius

Choose the Measurements>Circle>Center+Radius command to draw a circle with Center+Radius method on the specified Layer. Its radius is C1@33583.88um.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.10.2 Circle>Two Points

Choose the Measurements>Circle>Two Points command to draw a circle with Two
Points method on the specified layer.

**Note:** a) To check or modify the parameters of the selected **Object**, just select a single **Measurement Object** and the **Measurement Sidebar** will be activated automatically. Here you can edit the corresponding **Object** parameters to modify its properties; b) The **Appearance**, **Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the selected **Object** type (The type could be the same or different).

### 14.10.3 Circle>Three Points

Choose the **Measurements>Circle>Three Points** command to draw a circle with **Three Points** method on the specified layer.

**Note:** a) To check or modify the parameters of the selected **Object**, just select a single **Measurement Object** and the **Measurement Sidebar** will be activated automatically. Here you can edit the corresponding **Object** parameters to modify its properties; b) The **Appearance**, **Coordinates** on **Measurement Sidebar** will be enabled only when a single **Object** is selected. The **Calculation** will be effective for a single selected **Object** or multiple selected **Objects**. Its calculated items will depend on the selected **Object** type (The type could be the same or different).

### 14.11 Annulus

1. Find the **Annulus** center 1 and click mouse button to mark the **Annulus** center;

2. Move mouse to let the first circle superpose with the image circle, clicking the mouse left button;

3. Move mouse to let the second circle superpose the image circle, clicking the left mouse button. Two radiuses with number and the units will be displayed on the **Annulus**;
**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

**14.12 Two Circles**

**14.12.1 Two Circle>Center+Radius**

Draw two circles with Center+Radius method on the specified layer. After the two circles are drawn, a line connecting these two circle centers will be drawn.

**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

**14.12.2 Two Circle>Three Points**

Draw two circles with Three Points method on the specified layer. After the two circles are drawn, a line connecting these two circle centers will be drawn.

**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

**14.13 Arc**
1. Move mouse to mark the 1st point;

2. Move mouse to mark the 2nd point;

3. Move mouse to mark the 3rd point, then an Arc with Label and its Length will be drawn connecting these three points.

Note: a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

14.14 Text

1. Choose the Measurements>Text command;

2. Move mouse to mark the 1st point;

3. Move mouse to mark the 2nd point, a rectangle with dash line restrict the Text window size. After the mouse button is released, a dialog called Text will bring up for you to enter the Text and define the Text, Frame styles and adjust the Text positions.

4. Enter the text and click the right mouse button to end the Text object.
**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).

### 14.15 Polygon

1. Choose the Measurements>Polygon command;
2. Move mouse to mark the 1st point;
3. Move mouse to mark the 2nd point.
4. •••;
5. Move mouse to mark the nth point;
6. Repeat step1 to n to draw the other Polygon
7. Click the right mouse button to end the Polygon command

**Note:** a) To check or modify the parameters of the selected Object, just select a single Measurement Object and the Measurement Sidebar will be activated automatically. Here you can edit the corresponding Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will be enabled only when a single Object is selected. The Calculation will be effective for a single selected Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type could be the same or different).
## 14.16 Z Order

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Modify the selected Object's relative position to the uppermost place of all Objects on the Current layer.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Modify the selected Object's relative position to the lowest place of all Objects on the Current layer.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Modify the selected Object's relative position to the higher place of the two on the Current layer.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Modify the selected Object's relative position to the lower place of the two on the Current layer.</td>
</tr>
</tbody>
</table>
15 Options

15.1 Preferences

There are 7 pages for the Preference dialog. They are Quick Save, File, Print, Ruler and Grids, Cursor, Capture and Misc pages.

15.1.1 Quick Save Page

The File>Quick Save menu or the Quick Save icon on the toolbar will be enabled when a) a new image captured from the camera; b) an image window is created by choosing the File>Paste as New File menu.

File>Quick Save can save the file at quick way with no need to specify the file directory, file name and file format. All those are specified in Options>Preferences, Quick Save property page.

Directory: Enter the name of the drive and directory where the new image will be saved. You may either type the path information, or use the Browse button to locate it from a standard Browse Folder dialog.

Name Format: The year, month, date, hour, minute and second or nnnn(sequence) are used to as part of the file name. If more files are saved with in a second, a (xx) suffix is attached to the end of Name Format to avoid the possible name confliction. For the nnnn(sequence) Name Format, no suffix is needed.

File Prefix: Enter a file name prefix for Quick Save when generating files names for a series of images. This prefix will be combined with Name Format to form a final file name naming paradigm.
Help Manual

File Type: In this combobox, select the format in which you want the image to be saved (can be BMP, JPG, PNG, TIF). Click Option button to set the different parameters for encoding the file (For BMP format, the Option will be disabled. See File>Save As... menu about the details of the format encoding methods); If there are Measurement Objects over the image, the File Type will be chose as “ToupView File Type (*.tft)” by ToupView.

Sample: The final file name is shown at the right of the Sample label for reference.

Show the rename file dialog: The file name can be renamed according to this item. When this item is checked, a Rename dialog will pop up after choosing File>Quick Save command or click the Quick Save icon on the toolbar. The new name can be specified again according to the requirement.

15.1.2 File Page

One can check a file Extension for the specified file Format and its Abbr.(abbreviation), to determine whether or not it will be displayed in the Browse window or not (The checked Format can be displayed in the Browse window).

| Extension | Used to identify the file extension |
### 15.1.3 Print Page

One can set the Page Header and Page Footer in following format:

<table>
<thead>
<tr>
<th>&amp;f File Name</th>
<th>&amp;p Current Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;P Total Pages</td>
<td></td>
</tr>
<tr>
<td>%A Full weekday name</td>
<td>%b Abbreviated month name</td>
</tr>
<tr>
<td>%B Full month name</td>
<td>%c Date and time representation appropriate for locale</td>
</tr>
<tr>
<td>%d Day of month as decimal number (01 - 31)</td>
<td>%H Hour in 24-hour format (00 - 23)</td>
</tr>
<tr>
<td>%I Hour in 12-hour format (01 - 12)</td>
<td>%j Day of year as decimal number (001 - 366)</td>
</tr>
<tr>
<td>%m Month as decimal number (01 - 12)</td>
<td></td>
</tr>
</tbody>
</table>
%M Minute as decimal number (00 - 59)
%p Current local times A.M./P.M. indicator for 12-hour clock
%S Second as decimal number (00 - 59)
%U Week of year as decimal number, with Sunday as first day of week(00-53)
%w Weekday as decimal number (0 - 6; Sunday is 0)
%W Week of year as decimal number, with Monday as first day of week(00-53)
%x Date representation for current locale
%X Time representation for current locale
%y Year without century, as decimal number (00 - 99)
%Y Year with century, as decimal number
%z %Z Time-zone name or abbreviation; no characters if time zone is unknown
%% Percent sign

For example:

Choosing &f Date:%Y-%m-%d will print the file name and Date with yyyy-mm-dd format on the page header.

Choosing Page:&p/&P will print Page: 01/11 on the page footer (Suppose the current page is page 1 and the total pages is 11).

Print the measurement item: If there are measurement item overlaid on the image, check it will print these objects on the image. Measurement Sheet on the page;

Print the measurement table: If there are measurement item overlaid on the image, check it will print these objects’ Measurement Sheet on the page with;

Always use another paper: Print the Measurement Sheet data on a separate page;

Auto: Print the Measurement Sheet data just behind the image (if the image and data can be arrange in a single page) or on a separate page (if not);

Do not use another paper: Print the Measurement Sheet data just behind the image page;

Font: Choose the Font for the data.

15.1.4 Rulers and Grids Page
Choosing the View>Ruler and Grid>Setting command, or choosing the Preference command and clicking the Rulers and Grids page realize the same function.

Choosing the Preference command and clicking the Rulers and Grids page can set Ruler Color, Cursor Color of the Horizontal Ruler and Vertical Ruler for the video or image windows. The Grid Style, Line Style, and Line Color for the Grid overlaid on the video and image window can also be set.

Ruler Color: The Horizontal Ruler color and Vertical Ruler color; Default is blue (0,0,255);

Cursor Color: The Cursor color; When you are moving your mouse over the video/image window, there will be Horizontal Cursor and Vertical Cursor move on the Horizontal Ruler and Vertical Ruler moving at the same time indicating the current Cursor position in both directions. Default is Red (255,0,0);

Grid Style: The Grid Style can be No Grid, Auto Grid or Manual Grid. Default is No Grid;

Grid Line Style: The Line Style for the grid can be Solid, Dash, Dot or DashDot et al. Default is Solid;

Grid Line Color: The color of the grid line. Default is Red (255,0,0).

15.1.5 Cursor Page
This command will set the mouse cursor for the video and image window operations.
Select the **Horizontal** cross in:

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels), Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.

Select the **Vertical** cursor in:

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels), Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.

**Single** means single line. **Double** means two parallel lines. **1 Pixel** means the line space between the two lines is 1 pixel in distance. The other sizes also have this meaning.

Select the cursor shape from **Cross**, **Point**, and **Null**.

In the figure below, a cursor with **Double horizontal and vertical lines with 9 Pixels cross** (for the alignment application, the longer one) and the **Cursor as a Cross** was defined

15.1.6 Capture Page

If one wish to capture an image with many **Measurement** objects overlaid on the video window, the following settings should be defined first.
1. Choosing the **Options>Preferences** command, a dialog called **Preferences** will be brought up as shown below;

![Preferences dialog](image)

2. Clicking the **Capture** page and then checking **Capture with Marker and Watermark** or **Capture with Measurement**;

3. Click **Ok** to end the setup, or **Apply** to apply the setup, or **Cancel** to cancel the setup.

After the above steps are finished, if there are **Marker**, **Watermark** or **Measurement** objects overlaid above the video, choosing the **Capture>Capture Image** or clicking ![Camera Sidebar](image) on the **Camera Sidebar** will capture the image with **Marker**, **Watermark** or **Measurement** objects overlaid on the image.

**15.1.7 Misc Page**

The **Misc** page is mainly used for the control of the ToupView UI. It mainly includes:

1. ToupView’ special file format warning information;
2. Sidebars;
3. UI Style;
4. Language;
5. Privacy;

settings et al.
15.2 Measurements

This sheet has many pages. They are:

15.2.1 General page

The General page is shown below:

The calculation results keep: The combo box allows you to set the calculation results
accuracy among 1 decimal and 6 decimals. Default is 2 decimals;

**Label font size**: The Label is used to display the Measurement Objects dimensions. the Label font size is among 5 and 15; Default is 15;

**Label Color**: The Label Font color for the Measurement Objects dimensions; Default is red;

**Dimensions with unit**: If this box is checked, the Dimension will be displayed together with the unit for the Measurement Objects. If unchecked, only the Dimension will be displayed with the Measurement Objects.

**Label with name**: Checking Label with name will add a Prefix before the Measurement Objects number. The Prefix for the different Object can be specified in the Measurement Sidebar where there is an item called: Name. Here, we show an example for Line Object with and without Prefix L1 as below:

![Label examples](image)

15.2.2 Length Unit page

**Length Unit page**: One can select the Length Unit for the Measurements menu’s Objects on the Layer Measurement operation.

**Unit**: The system unit defined by the ToupView. It cannot be deleted;

**Current**: The Unit selected or checked;

**Type**: Type of unit. It can be System (Defined by ToupView) or User (Defined by the user) type;

**Scale**: Represents the ratio of "Meter by unit". For example, if the unit is µm, then "Meter by µm" should be 1000000, the Scale should be 1e+6;
Add: User can also define his own Unit. Clicking Add••• button and the Add Unit dialog will be brought up as above;

Here, one can enter the unit Name and Symbol in their fields. Here, we enter a name called Decimeter and its Symbol is dm, its Scale for Meter by Decimeter is 10. Click OK to end the Add Unit operation, or Cancel to cancel the Add Unit operation.

The final Length Unit list looks like the figure below:

You can find the Type is now named User. This means that this Unit is not defined by the System, but by the User.
On the Angle Unit page, one can select Radian, Degree, or PI as the Angle Unit.

Show all the angle units in the measurement sidebar will list all the Object Units in the Measurement Sidebar as shown above for reference.

15.2.4 Sheet page

See the View>Measurement Sheet menu to understand its functions.

1. To modify the Measurement Sheet's item order, click the item to highlight it, the Up or Down buttons will be enabled (If the item is in the third position, the Up button will be disabled, if the item is in the last position, the Down button will be disabled). Click the Up or Down buttons to modify the item position;

Note: The item Index and Name are always in grayed states, this means these two items cannot be modified (Both their hide/show states and their positions).

2. Checking/Unchecking the item will show/hide the item in the Measurement Sheet;

3. Clicking Default will return to the ToupView's default settings;

4. Both the name and order for Item 1(Index) and item 2(Name) cannot be changed.
15.2.5 Object page

The Measurement Object page list the Point, Line, Parallel, Two Parallels, Vertical, Angle, Rectangle, Circle, Arc, Annulus, Two Circles, Ellipse, Polygon, Scale Bar, Text characteristics. Their characteristics can be modified in this page according to the requirement. Different Object has different characteristics.

Click Defaults can return the all the modifications to the Default one.

15.3 Magnifications

Choose the Options>Magnification command to manage the calibrated Magnification.

If one has defined the 4x, 10X, 40X, 100X Magnifications, the Magnification dialog
should look like:

1. Highlight the **Magnification** item and the **Delete** button will be enabled. Click **Delete** to delete the selected item;

2. Highlight the **Magnification** item, click the **Up** or **Down** button to modify the **Magnification** list order; The **Up** or **Down** button will be disabled when the highlight item is at the first or last position;

3. Click **Clear All** to delete all of the **Magnification** items; If one wishes to use the **Magnification** later, a backup should be made first;

4. Click **Export** to back up the **Magnification** in a safe media. The file extension is “*.magn”;

5. After the new installation is finished, the **Magnification** can be import by choosing the **Options>Magnification** command and click **Import** to load the previously saved “*.magn” file;

6. If everything is ok, press **OK** to end the **Magnification** management dialog.

**15.4 Calibrate**

The detailed calibration steps are as follows:

1. Run ToupView;

2. Connect the camera to the computer and microscope;

3. Start the camera (Here, it is **UCMOS00350KPA**);
4. Switch the microscope object to 10X and put the TS-M1 micrometer in the middle of the microscope field and try to find the ruler clearly. Set the Unit to Pixel and the video Resolution to the maximum one (640X480 for UCMOS00350KPA) and Zoom ratio to 100% (see Pixel X X 100%); 

5. Choosing the Options>Calibrate command or clicking “○” on the toolbar, a red line with pixels number and 0.000um length is overlaid on the video window. At the same time, a dialog called Calibrate will be displayed over the video window; 

6. Try to align the two ends of the red line with the video ruler scale (Try to pull the red line as long as possible to keep the calibration accuracy); 

7. Enter or select the current microscope objective lens Magnification in the Magnification field. The current Magnification is 10X; 

8. Read the overlaid (by the red line) micro-ruler actual length and fill it in the Actual Length field, the current Actual Length is 450um. This Actual Length will also be displayed in the middle of the red line just behind the pixel number. At the same time, the Resolution will be calculated and displayed simultaneously in the Resolution field.
9. If everything is ok, click Ok to end the calibration. The Magnification 10X (This is the number you entered in the Magnification edit box) will be available in the Magnification dropdown combobox on the video window toolbar.

10. If you wish to make the measurement under this Magnification, choose 10X in the above Magnification dropdown combobox first and then choose Unit in the Unit dropdown list box which is just in the left of the Magnification’s dropdown combobox (User can also choose Unit through the Option>Measurements menu, a dialog called Measurement will be brought up. Click Length Unit page to display the Length Unit page and and checking Unit in the Current item.

Now, you can measure the objects with the selected Unit at ease.
10. The selected Resolution can be saved for the future image Measurement operations. If the Measurements are performed on the video, the objects and Resolution can be saved in the image with ToupView File Format (*.tft) for the future applications;

11. The other microscope Magnification such as 4X, 40X, 100X can also be defined just as the above steps. Thus when you switch the microscope objective lens, you just need to select the Magnification (40X for example) on the toolbar to perform the Measurement operations.

15.5 Edit Dye List

The Dye List can be used for the Process>Color Composite operation. The new Dye List feature in ToupView allows you to select from a list of dyes, or add your custom dyes to the list. The list of dyes (toupview.dye) is stored under C:\Program Files\ToupTek\ToupView directory.

When you choose Options>Edit Dye List command, you will see the Edit Dye List
dialog box:

The list includes any dye definitions found in the current location. When this feature is used to prompt for a specific dye, the list indicates the currently selected dye, or you may select a dye from the drop-down list.

**Name:** This list includes all dye definitions found in the current dye file. You may select a different dye from the drop-down list, and all the remaining controls will be updated to show the characteristics of the new dye.

**Emissions Wavelength:** This field displays the emissions wavelength for the dye you have chosen. You can adjust the emissions wavelength by entering a new value. The default color will change in response to changes in the emissions wavelength.

**Excitation wavelength:** The default wavelength for your dye is displayed here. You can adjust the wavelength by entering a new value.

**Color:** Use the slider to adjust the emissions wavelength for your dye, which also sets the default display color. (You can also use the Color button to select a specific color using a standard Windows color selection dialog) The color will change in response to changes in the emissions wavelength. Here you can change the color associated with the selected dye, or define a custom color. The color default is linked to the selection of a wavelength for your dye. If you change the Emissions Wavelength, the color displayed will be the standard color for that wavelength. To set a custom color, first you should set the wavelength and then edit the color.

![Color dialog box](image)

**New:** Clicking New will set up a new dye, this will invoke a dialog called New Dye.
Input your *New Dye* name and click *Ok* to end the dialog and click *Cancel* to cancel the input. This will return to the *Edit Dye List* again and the new name will be the default on in the Name list box. Try to set the *Emissions wavelength*, *Excitation wavelength*, *Color* for your new dye.

![New Dye dialog](image)

**Save**: Click *Save* on *Edit Dye List* to save your dye selection

**Close**: Click the *Close* button to end the *Edit Dye List* dialog:

### 15.6 Auto Correction

Set the low and high ranges for the *Image>Adjust>Auto Level* and *Image>Adjust>Auto Contrast* menus. The default value is 0.5% for both, but ToupView suggests this value be smaller than 1%.

![Auto Range dialog](image)

See *Image>Adjust>Auto Level* and *Image>Adjust>Auto Contrast* for details.
16 Windows

16.1 Close All

Choosing the Close All command to close all of the pictures opened or captured inside ToupView frame. If you have made any modifications to the pictures or if you have captured some pictures from the camera, choosing the Close All will let you finish the saving operations quickly.

If the above image windows exist, choosing the Windows>Close All command will bring up a Save Files dialog as below:

1. Clicking Yes on the Save Files dialog will close the Video and Browse window, Image windows that are not changed directly without ask anything. If there are newly created Image window, ToupView will bring up a Save As dialog to prompt you to enter the File name to save file.

If Save or Cancel is clicked in the Save As dialog, ToupView will return to the Save
Files dialog to continue the next file;

2. Clicking No on Save Files dialog will close the current image window without saving operation and return to the Save Files dialog to continue to the next file;

3. Clicking Cancel will cancel the Save Files dialog without doing anything;

4. Clicking Yes to All on Save Files dialog will always bring up Save As dialog to let you enter the File name to save files one by one until all of the files are saved;

5. Clicking No to All on Save Files dialog will close all of the image windows without saving them;

6. Clicking Batch Save on Save Files dialog will transfer the save process to File>Batch Save menu. Please check the File>Batch Save menu for details;

**Note:** If you have a lot of pictures opened and have made some modifications on them and want to close them quickly without saving anything, you may use this command and choose Step 5. All the images will be closed instantly, no warning will be given.

**16.2 Reset Window Layout**

Choosing this command will reset the ToupView window layout to the original one. The reset will be effective after restart.

**16.3 Windows***

Choosing the Windows>Windows*** will open a dialog box that lets you manage the currently opened windows.
The dialog allows you to manage large lists of open windows by assigning them into groups. Let us say you have eight windows open, but want to close four of them scattered through the list.

1. Choose the Windows>Windows... command;

2. Select the windows you want to close. Hold **Ctrl** or **Shift** key to select more than one at a time. Here, 4 windows are selected;

3. Click Close Window(s) button, those four selected windows will be closed, leaving the other files or captures available for editing;

You can use this command to switch to the checked window on a list by hitting **Activate** (or "bring up" from an icon multiple windows).
17 Help

17.1 Help Contents

Choose the Help>Help Contents command to load ToupView help file. The help file is in Portable Document Format (PDF).

PDF is a file format used to represent documents in a manner independent of application software, hardware, and operating systems. Each PDF file encapsulates a complete description of a fixed-layout flat document, including the text, fonts, graphics, and other information needed to display it. In 1991, Adobe Systems co-founder John Warnock outlined a system called "Camelot" that evolved into PDF.

While the PDF specification has been available free of charge since at least 2001, PDF was originally a proprietary format controlled by Adobe. It was officially released as an open standard on July 1, 2008, and published by the International Organization for Standardization as ISO 32000-1:2008. In 2008, Adobe published a Public Patent License to ISO 32000-1 granting royalty-free rights for all patents owned by Adobe that are necessary to make, use, sell and distribute PDF compliant implementations.

If your computer still does not install the PDF reader, please try to download from: http://www.adobe.com/downloads/

17.2 About

Display the related information about ToupView, including ToupView version, compatibility, built date and its developer’s www etc.

Clicking on the URL link will direct you to the address of the camera supplier. If you have any problem with the camera or ToupView, please feel free to contact your supplier.